Following Defaults Inside an AS

The following examples show how border routers can inject defaults inside your AS for your IGP to follow. Figure 12-10 illustrates the following scenario: AS3 is multihomed to two providers, AS1 and AS2. RTA is running EBGP with RTC, and RTF is running EBGP with RTD. Inside AS3, RTA and RTF are running IBGP. You will experiment with two situations: first, RTA and RTF having a direct physical connection, and second, RTA and RTF not having a direct physical connection. The latter scenario is used to demonstrate what could go wrong if your IGP traffic is following a default that conflicts with your BGP policies. Finally, RTG is an interior router that is running an IGP; RTG is following the default route 0/0 to reach networks outside AS3.

Figure 12-10. Following Defaults Inside the AS; Border Routers Connected


The scenario in which RTA and RTF are directly connected is easy; it is very hard for things to go wrong. As long as RTA and RTF are injecting defaults inside the IGP, traffic that reaches any of the BGP routers will find its way outside the AS. It is important that outbound traffic that reaches a BGP router does not go back to the non-BGP routers to avoid possible routing loops.

In case the border routers are not carrying full routes, they can accept a default to the providers to which they are connected. Both links can be used at the same time, or one link could be used as primary and the second as backup. Whichever policy you use, traffic will find its way out.

In the configurations shown in Example 12-38 and Example 12-39, RTA and RTF are accepting full routes from their respective providers. RTA and RTF are injecting defaults inside the AS (they are not getting any defaults themselves because they carry full routes). You will use OSPF as an IGP (other IGPs will be used in different scenarios later). Notice the presence of the default-information originate OSPF subcommand in both configurations.

Example 12-38. Following Defaults Inside the AS; Border Routers Connected: RTA Configuration
router ospf 10
 passive-interface Serial0
 network 172.16.0.0 0.0.255.255 area 0
 default-information originate always

router bgp 3
 no synchronization
 network 172.16.1.0 mask 255.255.255.0
 network 172.16.70.0 mask 255.255.255.0
 network 172.16.220.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.1.2 remote-as 3
 no auto-summary

ip as-path access-list 10 permit ^$

Example 12-39. Following Defaults Inside the AS; Border Routers Connected: RTF Configuration
router ospf 10
 network 172.16.0.0 0.0.255.255 area 0
 default-information originate always

router bgp 3
no synchronization
 network 172.16.1.0 mask 255.255.255.0
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.1.1 remote-as 3
 neighbor 172.16.1.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip as-path access-list 10 permit ^$

Example 12-40 shows the configuration for RTG.

Example 12-40. Following Defaults Inside the AS; Border Routers Connected: RTG Configuration
router ospf 10
 network 172.16.0.0 0.0.255.255 area 0

Note that the RTA and RTF configurations use the router ospf subcommand default-information originate with the always keyword. This command forces OSPF to inject a 0/0 default route into the OSPF domain at all times. The internal router RTG, which is running OSPF only, will receive the default from multiple sources and will follow the shortest internal metric. Routers that are closer (metric-wise) to RTA will use RTA for default; routers closer to RTF will use RTF.

The IP routing table for RTG in Example 12-41 reveals how RTG has set its gateway of last resort to RTA (172.16.70.1), which happens to be at a shorter internal metric than RTF.

Example 12-41. Following Defaults Inside the AS; Border Routers Connected: RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
    * - candidate default U - per-user static route, o - ODR
Gateway of last resort is 172.16.70.1 to network 0.0.0.0
   172.16.0.0/16 is subnetted, 5 subnets
O    172.16.220.0/24 [110/74] via 172.16.70.1, 00:03:27, Serial0
C    172.16.50.0/24 is directly connected, Serial1
O    172.16.20.0/24 [110/74] via 172.16.70.1, 00:03:27, Serial0
O    172.16.1.0/24 [110/74] via 172.16.70.1, 00:03:27, Serial0
C    172.16.70.0/24 is directly connected, Serial0
O*E2 0.0.0.0/0 [110/1] via 172.16.70.1, 00:03:27, Serial0

BGP Policies Conflicting with the Internal Default

Anytime internal routers are following defaults to reach routes unknown to the AS, you should be careful not to create routing loops. A routing loop occurs when router X follows a default toward router Y, which in turn uses router X to reach the destination. The traffic will end up bouncing between routers X and Y.

The default route 0/0 is injected differently from BGP into the IGP, depending on what IGP you are using. Different scenarios will be considered, utilizing OSPF, RIP, EIGRP, and IS-IS as the IGPs.

In the following scenarios, you will consider the case in which routers RTA and RTF in Figure 12-11 are not directly connected. As you will see, this will make configuration harder and more vulnerable to routing loops. Such configurations could be used in only some restricted cases.

Figure 12-11. Following Defaults Inside the AS; Border Routers Not Connected


Considering the network topology shown in Figure 12-11, assume that AS3 is setting its policies in a primary/backup environment where the NY link is primary, and the SF link is a backup. As such, RTA learns its IBGP routes with a higher local preference than its EBGP routes and will always direct its traffic toward its IBGP peer, RTF. In case RTG is receiving the 0/0 from both RTA and RTF, RTG must pick the default via RTF (primary); otherwise, a routing loop will occur. The following sequence of events explains why:

1.
RTG tries to send traffic to a destination outside AS3.

2.
RTG follows the default toward RTA.

3.
RTA has its BGP policies set to use RTF as the exit point.

4.
To reach RTF, RTA uses RTG as a first hop.

5.
RTG receives the traffic destined to the outside destination and forwards it back to RTA, and the loop occurs.

To avoid this situation, you can use any of the following methods:

  1. Make sure that RTA does not inject a 0/0 in the IGP unless the primary link goes down. In normal conditions, all traffic will follow the default toward RTF and will be able to exit the AS. In case of a NY link failure, RTA should start sending defaults in the IGP.

    This method works most easily in a primary/backup environment. In cases where the exit point is not defined, it is hard to figure out which router should send the default. In such cases, any border router that receives the traffic should be able to send it on its direct external link.

  2. Make sure that the border router (RTA) does not send the traffic back to the internal router (RTG), which already used it (RTA) as the default. This could be done by providing a shorter path (metric-wise) via the BGP routers—for example, by having a direct physical link between RTA and RTF. If RTG uses RTA as default, RTA will use its directly connected link to send the traffic back to RTF.

  3. Run a full IBGP mesh between RTA, RTG, and RTF. RTG would learn all routes via BGP.

  4. Manipulate the metrics in such a way that the internal router (RTG) always gets a lower metric via the primary.

We used the second method in the previous example. The third method is straightforward and will not be covered. In each of the following scenarios, you will consider a different IGP and use either the first or fourth method to solve the problem. Even though you will use just one method in addressing each case, both methods 1 and 4 can be used with any of the IGPs.

To make the problem easier, you will assume that RTA and RTF are dynamically getting a 0/0 default from their providers (regardless of whether they need it). The following sections experiment with how injecting defaults is treated in a Cisco environment.

Using OSPF as the IGP

You can inject the 0/0 default into OSPF by using the following router command:

default-information originate [always] [metric metric-value] [metric-type type-value] [route-map map-name]

The default-information originate (without the always keyword) will inject a default 0/0 into OSPF only if the router itself has a default. The always keyword cannot be used here because, in case of a link failure, the border router would continue to inject a default in the IGP, even though it cannot deliver the traffic anymore. (Remember that there is no direct link between border routers.)

If RTA and RTF in Figure 12-11 are both configured with the router command default-information originate, this is what could happen:

1.
RTA receives a 0/0 via EBGP and IBGP.

2.
Because RTA is preferring everything via RTF (higher local preference), RTA will prefer the 0/0 via IBGP.

3.
Because RTA has a default (via BGP), it will start injecting the default into IGP.

You are in a situation in which both routers are generating defaults, and a loop might occur.

You might say that because the NY link is the primary, RTA should not send any defaults. This reasoning will fail, however, because if the NY link goes down, RTF stops, advertising a 0/0 into the IGP. RTA is not sending any defaults either, so traffic cannot exit the AS.

The solution to these problems is to have RTA and RTF inject a default only if they have a default themselves and only if the default they prefer comes from EBGP. When RTA detects that it is preferring the 0/0 via EBGP rather than IBGP, it will get an indication that there is a problem with the NY link and will start sending the default. This could be achieved by using a route map in conjunction with the default-information originate router command, as demonstrated in Example 12-42.

Example 12-42. Using a Default Only Under Certain Conditions: RTA Configuration
router ospf 10
 passive-interface Serial0
 network 172.16.0.0 0.0.255.255 area 0
 default-information originate route-map SEND_DEFAULT_IF

router bgp 3
no synchronization
 network 172.16.220.0 mask 255.255.255.0
 network 172.16.70.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.50.1 remote-as 3
 neighbor 172.16.50.1 route-map setlocalpref in
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 1 permit 0.0.0.0
access-list 2 permit 172.16.20.1

route-map setlocalpref permit 10
 set local-preference 300

route-map SEND_DEFAULT_IF permit 10
 match ip address 1
 match ip next-hop 2

Note the route map SEND_DEFAULT_IF that is associated with the default-information originate router command. This route map matches on the condition that the 0/0 default (access-list 1) has a next hop of 172.16.20.1 (access-list 2). This satisfies the condition that the 0/0 is learned via EBGP rather than IBGP. If this is the case, RTA will detect a link failure in NY and will start injecting its own 0/0 into OSPF.

The second route map setlocalpref assigns a value of 300 to all the RTA's IBGP routes. This makes all IBGP routes preferred over EBGP routes.

As defined by the configuration in Example 12-43, RTF also originates a default into OSPF only on the condition that RTF is learning the default from its exterior link (NEXT_HOP 192.68.5.2). In case of a NY link failure, RTF will stop advertising a 0/0, even though it might be getting a 0/0 from RTA via IBGP.

Example 12-43. Stop Advertisement of Default Under Specific Conditions: RTF Configuration
router ospf 10
 network 172.16.0.0 0.0.255.255 area 0
 default-information originate route-map SEND_DEFAULT_IF

router bgp 3
no synchronization
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.70.1 remote-as 3
 neighbor 172.16.70.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 1 permit 0.0.0.0
access-list 2 permit 192.68.5.2

route-map SEND_DEFAULT_IF permit 10
 match ip address 1
 match ip next-hop 2

As defined in Example 12-44, RTG is running OSPF only and following the 0/0 default for routes outside AS3.

Example 12-44. Following Default for External Routes: RTG Configuration
router ospf 10
 network 172.16.0.0 0.0.255.255 area 0

Example 12-45 shows RTA's IP routing table. Note that RTA prefers the 0/0 default via its IBGP peer RTF with NEXT_HOP 172.16.50.1. Because the NEXT_HOP is different from 172.16.20.1 (the external peer), RTA will not inject any default inside OSPF.

Example 12-45. RTA IP Routing Table
RTA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
    * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0

B  192.68.6.0/24 [200/0] via 172.16.50.1, 00:03:06
B  192.68.11.0/24 [200/0] via 172.16.50.1, 00:03:06
B  193.78.0.0/16 [200/0] via 172.16.50.1, 00:03:06
   172.16.0.0/16 subnetted, 4 subnets
C    172.16.20.0/24 is directly connected, Serial0
C    172.16.220.0/24 is directly connected, Ethernet1
O    172.16.50.0/24 [110/164] via 172.16.70.2, 02:17:37, Serial1
C    172.16.70.0/24 is directly connected, Serial1
B* 0.0.0.0/0 [200/0] via 172.16.50.1, 00:03:07

Example 12-46 shows RTG's IP routing table. Note how RTG sets its default to RTF. Both the BGP policies and the IGP defaults are now in sync.

Example 12-46. RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
    * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0

   172.16.0.0/16 is subnetted, 4 subnets
O    172.16.20.0/24 [110/128] via 172.16.70.1, 02:21:04, Serial0
O    172.16.220.0/24 [110/74] via 172.16.70.1, 02:21:04, Serial0
C    172.16.50.0/24 is directly connected, Serial1
C    172.16.70.0/24 is directly connected, Serial0
O*E2 0.0.0.0/0 [110/1] via 172.16.50.1, 00:41:26, Serial1

In case the NY link fails, RTA will learn the BGP 0/0 via its external link with next hop 172.16.20.1 and will inject a default into OSPF.

Redistributing the 0/0 from BGP into OSPF via the redistribute router command is not allowed or implemented.

Using RIP as the IGP

The Cisco RIP implementation behaves differently from OSPF when dealing with the 0/0 defaults. The BGP-learned 0/0 default is automatically injected into RIP. A default-metric router command is required under the RIP process to assign a metric (hop count) to the default. In our example (Figure 12-11), assume that RTA, RTF, and RTG are running RIP. You will set the metric of the 0/0 injected into RIP by RTA in such a way that the internal router (RTG) always prefers RTF.

The configuration for RTA in Example 12-47 will set the 0/0 default metric to 5. Note that no redistribution was necessary to inject the BGP default into RIP.

Example 12-47. Using RIP as the IGP: RTA Configuration
router rip
 passive-interface Serial0
 network 172.16.0.0
 default-metric 5

router bgp 3
no synchronization
 network 172.16.220.0 mask 255.255.255.0
 network 172.16.70.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.50.1 remote-as 3
 neighbor 172.16.50.1 route-map setlocalpref in
 no auto-summary

ip as-path access-list 10 permit ^$

route-map setlocalpref permit 10
 set local-preference 300

The configuration for RTF in Example 12-48 will inject the 0/0 into RIP with a hop count of 1.

Example 12-48. Using RIP as the IGP: RTF Configuration
router rip
network 172.16.0.0
default-metric 1

router bgp 3
no synchronization
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.70.1 remote-as 3
 neighbor 172.16.70.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip as-path access-list 10 permit ^$

The configuration for RTG in Example 12-49 runs RIP only and follows the 0/0 default for routes outside AS3.

Example 12-49. Using RIP as the IGP: RTG Configuration
router rip
network 172.16.0.0

Example 12-50 shows RTG's IP routing table. Note that RTG has set its default to RTF because of the lower metric of 1.

Example 12-50. RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
    * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0

   172.16.0.0/16 is subnetted, 4 subnets
R    172.16.220.0/24 [120/1] via 172.16.70.1, 00:00:03, Serial0
C    172.16.50.0/24 is directly connected, Serial1
R    172.16.20.0/24 [120/1] via 172.16.70.1, 00:00:03, Serial0
C    172.16.70.0/24 is directly connected, Serial0
R* 0.0.0.0/0 [120/1] via 172.16.50.1, 00:00:22, Serial1

Note

If more conditions are needed to inject the 0/0 into RIP, redistribution and route maps could be used to inject the default from BGP into RIP.


Using EIGRP as the IGP

BGP-learned defaults are injected into EIGRP via redistribution. The 0/0 metric needs to be converted into an EIGRP-compatible metric by using the default-metric router subcommand.

The configuration for RTA in Example 12-51 will inject its default with a high metric in such a way that the internal router (RTG) always gets a lower metric via RTF.

Example 12-51. Using EIGRP as the IGP: RTA Configuration
router eigrp 1
 redistribute bgp 3 route-map DEFAULT_ONLY
 passive-interface Serial0
 network 172.16.0.0
 default-metric 5 100 250 100 1500

router bgp 3
 no synchronization
 network 172.16.70.0 mask 255.255.255.0
 network 172.16.220.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.50.1 remote-as 3
 neighbor 172.16.50.1 route-map setlocalpref in
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 5 permit 0.0.0.0

route-map setlocalpref permit 10
 set local-preference 300

route-map DEFAULT_ONLY permit 10
 match ip address 5

RTA uses a route map DEFAULT_ONLY to match on the default route 0/0. Any other updates will be prevented from being redistributed into EIGRP. RTA also sets the metric by using the default-metric router subcommand.

In the same manner, the configuration for RTF in Example 12-52 redistributes only the 0/0 into EIGRP using the route map DEFAULT_ONLY.

Example 12-52. Using EIGRP as the IGP: RTF Configuration
router eigrp 1
 redistribute bgp 3 route-map DEFAULT_ONLY
 network 172.16.0.0
 default-metric 1000 100 250 100 1500

router bgp 3
 no synchronization
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.70.1 remote-as 3
 neighbor 172.16.70.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 5 permit 0.0.0.0

route-map DEFAULT_ONLY permit 10
 match ip address 5

RTF uses the default-metric 1000 100 250 100 1500 statement to set its default metric to an EIGRP-compatible metric. Note the bandwidth portion (1000) of the default-metric statement in RTF, which is much higher than the bandwidth in RTA (5). This makes the metric from RTF much lower than the one from RTA.

As illustrated by the configuration in Example 12-53, RTG is running EIGRP only and is following the default for all routes outside AS3.

Example 12-53. Using EIGRP as the IGP: RTG Configuration
router eigrp 1
 network 172.16.0.0

Example 12-54 shows RTG's IP routing table. Note that RTG follows the default toward RTF.

Example 12-54. RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
      * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0

   172.16.0.0/16 is subnetted, 4 subnets
D    172.16.220.0/24 [90/2195456] via 172.16.70.1, 00:12:17, Serial0
C    172.16.50.0/24 is directly connected, Serial1
D    172.16.20.0/24 [90/2681856] via 172.16.70.1, 00:12:17, Serial0
C    172.16.70.0/24 is directly connected, Serial0
D*EX 0.0.0.0/0 [170/3097600] via 172.16.50.1, 00:07:40, Serial1

Using IGRP as the IGP

IGRP does not understand the 0.0.0.0 default. To set a default inside IGRP, the ip default-network global command needs to be set on RTA and RTF. The default network used needs to be redistributed into IGRP to set the default on the internal routers. A default metric needs to be set for successful redistribution.

As illustrated by the configuration for RTA in Example 12-55, RTA sets network 192.68.6.0/24 (or any other classful network learned via BGP) to be the default network. RTA will redistribute that network only into IGRP.

Example 12-55. Using IGRP as the IGP: RTA Configuration
router igrp 1
 passive-interface Serial0
 redistribute bgp 3 route-map DEFAULT_ONLY
 network 172.16.0.0
 default-metric 5 100 250 100 1500

router bgp 3
 no synchronization
 network 172.16.70.0 mask 255.255.255.0
 network 172.16.220.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.50.1 remote-as 3
 neighbor 172.16.50.1 route-map setlocalpref in
 no auto-summary

ip default-network 192.68.6.0
ip as-path access-list 10 permit ^$

access-list 5 permit 192.68.6.0 0.0.0.255

route-map setlocalpref permit 10
 set local-preference 300

route-map DEFAULT_ONLY permit 10
 match ip address 5

As illustrated by the configuration for RTF in Example 12-56, RTF also sets its default, to 192.68.6.0/24, and redistributes the default, with a better metric, into IGRP.

Example 12-56. Using IGRP as the IGP: RTF Configuration
router igrp 1
 redistribute bgp 3 route-map DEFAULT_ONLY
 network 172.16.0.0
 default-metric 1000 100 250 100 1500

router bgp 3
 no synchronization
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.70.1 remote-as 3
 neighbor 172.16.70.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip default-network 192.68.6.0
ip as-path access-list 10 permit ^$

access-list 5 permit 192.68.6.0 0.0.0.255

route-map DEFAULT_ONLY permit 10
 match ip address 5

As illustrated by the configuration for RTG in Example 12-57, RTG is running IGRP only and is following the default for all routes outside AS3.

Example 12-57. Using IGRP as the IGP: RTG Configuration
router igrp 1
 network 172.16.0.0

Example 12-58 shows the RTG IP routing table. Note that RTG follows the default toward RTF.

Example 12-58. RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
          * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 192.68.6.0

I*   192.68.6.0/24 [100/8576] via 172.16.50.1, 00:00:32, Serial1
   172.16.0.0/16 is subnetted, 4 subnets
I    172.16.220.0/24 [100/8576] via 172.16.70.1, 00:00:32, Serial0
C    172.16.50.0/24 is directly connected, Serial1
I    172.16.20.0/24 [100/10476] via 172.16.70.1, 00:00:32, Serial0
C    172.16.70.0/24 is directly connected, Serial0

Using IS-IS as the IGP

IS-IS is similar to OSPF; it uses the default-information originate router subcommand.

In the configuration for RTA in Example 12-59, RTA originates a default into IS-IS only on the condition that RTA learns the default from its exterior link.

Example 12-59. Using IS-IS as the IGP: RTA Configuration
router isis 100
 redistribute connected
 default-information originate route-map SEND_DEFAULT_IF
 net 49.0001.0000.0c00.000a.00

router bgp 3
no synchronization
 network 172.16.220.0 mask 255.255.255.0
 network 172.16.70.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 filter-list 10 out
 neighbor 172.16.50.1 remote-as 3
 neighbor 172.16.50.1 route-map setlocalpref in
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 1 permit 0.0.0.0
access-list 2 permit 172.16.20.1

route-map SEND_DEFAULT_IF permit 10
 match ip address 1
 match ip next-hop 2

In the configuration for RTF in Example 12-60, RTF originates a default into IS-IS on the condition that RTF learns the default from its exterior link.

Example 12-60. Using IS-IS as the IGP: RTF Configuration
router isis 100
 default-information originate route-map SEND_DEFAULT_IF
 net 49.0001.0000.0c00.000c.00

router bgp 3
no synchronization
 network 172.16.50.0 mask 255.255.255.0
 neighbor 172.16.70.1 remote-as 3
 neighbor 172.16.70.1 next-hop-self
 neighbor 192.68.5.2 remote-as 2
 neighbor 192.68.5.2 filter-list 10 out
 no auto-summary

ip as-path access-list 10 permit ^$

access-list 1 permit 0.0.0.0
access-list 2 permit 192.68.5.2

route-map SEND_DEFAULT_IF permit 10
 match ip address 1
 match ip next-hop 2

In the configuration for RTG in Example 12-61, RTG runs IS-IS and follows the 0/0 default for routes outside AS3.

Example 12-61. Using IS-IS as the IGP: RTG Configuration
router isis 100
 net 49.0001.0000.0c00.000b.00

Example 12-62 shows RTG's IP routing table; note how RTG follows the default toward RTF.

Example 12-62. RTG IP Routing Table
RTG#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
          * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0

   172.16.0.0/16 is subnetted, 4 subnets
i L1    172.16.220.0/24 [115/20] via 172.16.70.1, Serial0
i L1    172.16.20.0/24 [115/20] via 172.16.70.1, Serial0
C       172.16.50.0/24 is directly connected, Serial1
C       172.16.70.0/24 is directly connected, Serial0
i*L2 0.0.0.0/0 [115/10] via 172.16.50.1, Serial1

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
44.203.58.132