© The Author(s), under exclusive license to APress Media, LLC, part of Springer Nature 2021
R. CardonaThe Fast-Track Guide to VXLAN BGP EVPN Fabrics https://doi.org/10.1007/978-1-4842-6930-5_5

5. VXLAN Fabric to External Network Connectivity

Rene Cardona1  
(1)
California, CA, USA
 

How can you allow a VXLAN fabric to talk to an external network? Which implementation options are available? This is what Chapter 5 is all about. When it comes to interfacing your fabric to an external network, designate your border leaf to perform this role. It doesn’t matter if your external network is running dynamic route protocols or static routes. It still attaches to the border leaf since it’s the entry point to your fabric. Let’s explore and configure the available options.

BGP to OSPF Route Redistribution

An external campus network needs to communicate with the data center. The campus network is running OSPF, and you want to peer in OSPF, but your fabric propagates all tenant routes using BGP. You need to redistribute OSPF to BGP so you can learn all the campus side routes in your VXLAN fabric. There are three tenants, but only two should perform OSPF adjacency to the campus network. Please review the design specifics in Tables 5-1 and 5-2 and review the architecture diagram shown in Figure 5-1.
Table 5-1

Tenant-A

Campus Network

VLAN ID

IP

User VLAN

10

10.0.0.1/23

Table 5-2

Tenant-B

Campus Network

VLAN ID

IP

User VLAN

15

10.10.0.1/23

Staff VLAN

20

10.20.0.1/23

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig1_HTML.jpg
Figure 5-1

A campus network is connected to border Leaf-01 and Leaf-02. The campus network is configured with two Catalyst 9000s in a virtual stack

The goal is to get the campus core peered to the fabric border leafs. You want to provide access to both tenant-a and tenant-b, but you also want to avoid tenant-a from reaching tenant-b via the campus core. You want to filter the routes that are not shared between neighbors. Let’s perform the configurations.

Campus Core

The campus core has a single MC-LAG or, in the Cisco world, a multi-chassis EtherChannel northbound to DC1-Leaf-01 and DC1-Leaf-02. Both tenants peer to the core switch using OSPF (see Tables 5-3 and 5-4). You use VLAN interfaces to peer OSPF and allow a designated “peering” VLAN ID for each tenant.
  • Tenant-A – Leaf-01 VLAN 101

  • Tenant-A – Leaf-02 VLAN 102

  • Tenant-B – Leaf-01 VLAN 201

  • Tenant-B – Leaf-02 VLAN 202

Table 5-3

Tenant-A OSPF Links

Tenant-A Leaf-01

CORE

172.16.101.1/30

172.16.101.2/30

Tenant-A Leaf-02

CORE

172.16.102.1/30

172.16.102.2/30

Table 5-4

Tenant-B OSPF Links

Tenant-B Leaf-01

CORE

172.16.201.1/30

172.16.201.2/30

Tenant-B Leaf-02

CORE

172.16.202.1/30

172.16.202.2/30

The first step is to create the OSPF process for each VRF tenant. You could also create a single OSPF process then nest the tenants under it. But I like to have a separate process per tenant. Let’s configure Leaf-01 first (see Listing 5-1) and then Leaf-02 (see Listing 5-2) .

router ospf Tenant-A
 vrf Tenant-A
  router-id 172.16.101.1
router ospf Tenant-B
 vrf Tenant-B
  router-id 172.16.201.1
vlan 101
 name A-OSPF_CORE
 vn-segment 1000101
vlan 201
 name B-OSPF_CORE
 vn-segment 1000201
Int vlan 101
 vrf member Tenant-A
 ip router ospf Tenant-A area 0
 ip address 172.16.101.1/30
 fabric forwarding mode anycast-gateway
 no shut
Int vlan 201
 vrf member Tenant-B
 ip router ospf Tenant-B area 0
 ip address 172.16.201.1/30
 fabric forwarding mode anycast-gateway
 no shut
int nve 1
 member vni 1000101
  mcast-group 224.1.1.101
  suppress-arp
 member vni 1000201
  mcast-group 224.1.1.201
  suppress-arp
evpn
vni 1000101 l2
 rd auto
 route-target both auto
vni 1000201 l2
 rd auto
 route-target both auto
Listing 5-1

DC1-Leaf-01

router ospf Tenant-A
 vrf Tenant-A
  router-id 172.16.102.2
router ospf Tenant-B
 vrf Tenant-B
  router-id 172.16.202.2
vlan 102
 name A-OSPF_CORE
 vn-segment 1000102
vlan 202
 name B-OSPF_CORE
 vn-segment 1000202
Int vlan 102
 vrf member Tenant-A
 ip router ospf Tenant-A area 0
 ip address 172.16.102.1/30
 fabric forwarding mode anycast-gateway
 no shut
Int vlan 202
 vrf member Tenant-B
 ip router ospf Tenant-B area 0
 ip address 172.16.202.1/30
 fabric forwarding mode anycast-gateway
 no shut
int nve 1
 member vni 1000102
  mcast-group 224.1.1.102
  suppress-arp
 member vni 1000202
  mcast-group 224.1.1.202
  suppress-arp
evpn
vni 1000102 l2
 rd auto
 route-target both auto
vni 1000202 l2
 rd auto
 route-target both auto
Listing 5-2

DC1-Leaf-02

I’ve configured OSPF process IDs for both tenant-A and tenant-B. I’ve also allocated a set of VLANs in Leaf-01 and Leaf-02 to peer OSPF for both tenants. Now you need to confirm connectivity to the campus core Switch (SW). For your convenience, I’m providing the core configuration (see Listing 5-3).
router ospf 1
router-id 3.3.3.3
vlan 101
name tenantA_Leaf01_OSPF
vlan 102
name TenantA_Leaf02_OSPF
vlan 201
name TenantB_Leaf01_OSPF
vlan 202
name TenantB_Leaf02_OSPF
int vlan 101
no shut
ip address 172.16.101.2 255.255.255.252
ip ospf 1 area 0
int vlan 102
no shut
ip address 172.16.102.2 255.255.255.252
ip ospf 1 area 0
int vlan 201
no shut
ip address 172.16.201.2 255.255.255.252
ip ospf 1 area 0
int vlan 202
no shut
ip address 172.16.202.2 255.255.255.252
ip ospf 1 area 0
Listing 5-3

Campus Core Configuration

After validating that all the required configurations are in place, let’s confirm if you can see OSPF adjacency for both tenants on both leafs facing the core switch (see Figures 5-2, 5-3, 5-4, and 5-5).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig2_HTML.jpg
Figure 5-2

DC1-Leaf-01 tenant-A

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig3_HTML.jpg
Figure 5-3

DC1-Leaf-01 tenant-B

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig4_HTML.jpg
Figure 5-4

DC1-Leaf-02 tenant-A

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig5_HTML.jpg
Figure 5-5

DC1-Leaf-02 tenant-B

You can confirm that the tenants on both Leaf-01 and Leaf-02 have OSPF adjacency to the campus core.

Now you can begin advertising the tenant networks in the campus network. The first thing that I did was redistribute the connected SVIs to OSPF. You can accomplish it by redistributing route tags in OSPF. Let’s go ahead with the configuration. You configure the networks for each tenant, and then you configure the redistribution into OSPF. Apply to both leafs (see Listings 5-4 and 5-5).
Vlan 10
 name USERS-Tenant-A
 vn-segment 1001010
int vlan 10
 description USERS
 vrf member Tenant-A
 ip address 10.0.0.1/23
 fabric forwarding mode anycast-gateway
 no shut
int nve 1
member vni 1001010
 mcast-group 224.1.10.10
 suppress-arp
evpn
 vni 1001010 l2
 rd auto
 route-target both auto
! Interface Redistribution to OSPF
int vlan 10
 ip address 10.0.0.1/23 tag 11
route-map Tenant-A-Vlans-OSPF permit 10
 match tag 11
router ospf Tenant-A
 vrf Tenant-A
 redistribute direct route-map Tenant-A-Vlans-OSPF
Listing 5-4

Tenant-A

Vlan 15
 name USERS-Tenant-B
 vn-segment 1001015
Vlan 20
Name Staff-Tenant-B
Vn-segment 1001120
int vlan 15
 description USERS
 vrf member Tenant-B
 ip address 10.10.0.1/23
 fabric forwarding mode anycast-gateway
 no shut
int vlan 20
 description STAFF
 vrf member Tenant-B
 ip address 10.20.0.1/23
 fabric forwarding mode anycast-gateway
 no shut
int nve 1
 member vni 1001015
  mcast-group 224.1.10.15
  suppress-arp
 member vni 1001120
  mcast-group 224.1.10.20
  suppress-arp
evpn
vni 1001015 l2
rd auto
route-target both auto
vni 1001120 l2
rd auto
route-target both auto
Listing 5-5

Tenant-B

Interface Redistribution to OSPF

Let’s redistribute in Listing 5-6.
int vlan 15
 ip address 10.10.0.1/23 tag 22
int vlan 20
 ip address 10.20.0.1/23 tag 22
route-map Tenant-B-Vlans-OSPF permit 10
 match tag 22
router ospf Tenant-B
 vrf Tenant-B
 redistribute direct route-map Tenant-B-Vlans-OSPF
Listing 5-6

After executing the command “show ip route” we can confirm route redistribution into OSPF from the VXLAN fabric

Let’s confirm that the OSPF routes were built at the campus core switch from the VXLAN tenants.

Figure 5-6 shows the campus core route table.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig6_HTML.jpg
Figure 5-6

Campus core route table

The next step is to filter any tenant-A and tenant-B routes from being advertised between each other by using the campus core. Let’s do some route filtering to accomplish that. Let’s look at Leaf-01 and Leaf-02. The routes from tenant-B are shown in tenant-A and vice versa.

Figure 5-7 shows Leaf-01 tenant-A and tenant-B .
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig7_HTML.jpg
Figure 5-7

Leaf-01 tenant-A and tenant-B

The tenants can reach each other through the campus core switch. You need to avoid the tenant’s from seeing each other. The campus core network is only allowed to reach both tenants.

Let’s now add a route filter on Leaf-01 to filter incoming OSPF routes from tenants leaked in OSPF via the campus core. In summary, you create a route map with the “deny” action, and then match all the interfaces participating in the OSPF process.

OSPF Inbound Route Filtering Configuration

Apply OSPF inbound route filtering configuration to both Leaf-01 and Leaf-02, as shown in Listing 5-7.
route-map Deny-OSPF-Routes deny 10it right to stop
  match interface Vlan101 Vlan102 Vlan201 Vlan202
router ospf Tenant-A
  vrf Tenant-A
    table-map Deny-OSPF-Routes filter
router ospf Tenant-B
  vrf Tenant-B
    table-map Deny-OSPF-Routes filter
Listing 5-7

Without any route filtering in-place, Tenant-A and Tenant-B can reach each other via the campus core

Figure 5-8 shows the post-change result on Leaf-01 in tenant-A and tenant-B.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig8_HTML.jpg
Figure 5-8

Post-change result on Leaf-01 in tenant-A and tenant-B

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig9_HTML.jpg
Figure 5-9

After Applying route filtering we can confirm that Tenant-A and Tenant-B can’t reach each other

You no longer see routes advertised from the campus core to the tenants. You need to be aware of an active OSPF peering to both Leaf-01 and Leaf-02. To avoid any asymmetric routing issues, you must make sure that only one OSPF path is active at a time. How do you accomplish this? First, you need to identify which leaf becomes the active path for the campus core. I chose Leaf-01 to become the active OSPF path to the campus network. On the campus core side, you need to configure OSPF costing to influence routes to be preferred to either OSPF neighbor, in this case, Leaf-01. Do a simple OSPF costing configuration that is lower on the VLAN interfaces peering to Leaf-01. VLANs 101 and 201 are the designated OSPF peering interfaces between Leaf-01 and the campus core. You’ll see more of this in the next section.

Listing 5-8 shows the campus core OSPF cost configuration.
int vlan 101 (TO LEAF1)
ip ospf cost 1
int vlan 102 (TO LEAF2)
ip ospf cost 100
int vlan 201 (TO LEAF1)
ip ospf cost 1
int vlan 202 (TO LEAF2)
ip ospf cost 100
Listing 5-8

Campus Core OSPF Cost Configuration

Adding the static OSPF cost values, you now confirm that only one active OSPF route is active for all advertised tenant networks. In my configuration, I set the lowest cost value possible to elect Leaf-01 as the primary path. If Leaf-01 goes down, Leaf-02 starts advertising its path. Let’s verify (see Figure 5-10).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig10_HTML.jpg
Figure 5-10

By setting up OSPF costing on any layer 3 interface participating in OSPF we can pin traffic to be preferred via a specific path

As you can see, there is one active route path via Leaf-01. Asymmetric routing issues are very common to face in VXLAN spines and leafs since the route paths are more elastic. I can route in many directions, but I still need to make sure that the traffic flow remains symmetric. In a nutshell, you send traffic one way, but the return traffic has a better path advertised via another leaf or so. This causes your asymmetric route flow issue.

A better way to explain it is by describing an asymmetric and symmetric flow sample. The diagrams presented in Figure 5-11 and Figure 5-12 are two examples of fabric efficiency. The diagram shown in Figure 5-11 is the asymmetric route issue using a firewall between the two tenants. Figure 5-12 is a symmetric route flow sample with the same scenario but traffic correctly pinned in one direction.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig11_HTML.jpg
Figure 5-11

In asymmetric routing issues, traffic does not return using the original path it came from. Due to many factors, mostly due to poor routing design and/or path selection

../images/504299_1_En_5_Chapter/504299_1_En_5_Fig12_HTML.jpg
Figure 5-12.

A symmetric route path between two tenants behind an external firewall

Asymmetric Route Issues in VXLAN BGP EVPN

Figure 5-11 describes each hop between a client tenant PC trying to communicate to the web servers tenant. By following each hop in the diagram, you see that the return traffic does not flow using the same path as the source request traffic from the client PC.

  • HOP 1: Client tenant PC sends a request to a web server. Leaf-04 sends the request to the VXLAN fabric. Traffic lands in Leaf-01 since it’s the preferred path to the web servers tenant via EVPN.

  • HOP 2: Leaf-01 sends the request to the external firewall since there’s an OSPF route advertised to the web server tenant.

  • HOP 3: Traffic leaves the firewall and lands in Leaf-02 since there’s no preferred path to the web server’s tenant. Leaf-02 sends the request to the web server’s tenant.

  • HOP 4: A server on the web server tenant replies to the request. Leaf-02 receives the request and forwards it to Leaf-04 instead of using the source path via the firewall peered in OSPF. The route to the client tenant is preferred over EVPN rather than OSPF.

  • HOP 5: At this point, the request fails to return due to an asymmetric route. The return traffic uses a different path due to OSPF equal-cost path between Leaf-01 and Leaf-02.

Symmetric Routing in VXLAN BGP EVPN

By confirming a symmetric route path, you guarantee that all requests and replies follow the same route path. In the diagram shown in Figure 5-12, you see the same scenario covered in the asymmetric route discussion. The difference is that the server traffic returns to the client using the same route path. How do you accomplish this? By making sure that you only configure a lower cost or distance in the dynamic route protocol, you are implementing so the traffic returns in the same direction it came from.

OSPF to BGP Route Redistribution

You can ensure that the traffic flows symmetrically by configuring OSPF costing or BGP distance (depending on which one you are using). Let’s configure and advertise the VRFs in a symmetric path. Let’s designate Leaf-01 to be the primary path to both VRFs. There is a network on the campus core that you want to reach. The address space is 10.100.10.0/24. All leafs should prefer Leaf-01 to reach this network. Leaf-02 should remain as a standby path to the destination of 10.100.10.0/24.

Routes Before Changes

Figure 5-13 illustrates tenant-A VRF on Leaf-01.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig13_HTML.jpg
Figure 5-13

Tenant-A VRF on Leaf-01

Figure 5-14 illustrates tenant-A VRF on Leaf-02.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig14_HTML.jpg
Figure 5-14

Tenant-A VRF on Leaf-02

In Leaf-02, the preferred path is still local to the campus core. You want to re-route the traffic from all leafs to prefer Leaf-01 then Leaf-01 forward to the campus core. You need to fix this by redistributing OSPF to BGP and tweaking the BGP distance, so it is preferred via Leaf-01 using EVPN type-5 route advertisements.

Redistribute OSPF to BGP EVPN on Leaf-01.
route-map OSPF-to-BGP permit 10
  match route-type internal external type-1 type-2
router bgp 65501
  vrf Tenant-A
    address-family ipv4 unicast
      redistribute ospf Tenant-A route-map OSPF-to-BGP
Modify BGP distance on Tenant-A in Leaf-02:
router bgp 65501
vrf Tenant-A
    address-family ipv4 unicast
      advertise l2vpn evpn
      distance 20 90 220
You have accomplished a few things. First, you redistributed all OSPF routes learned in Leaf-01 to the VXLAN fabric via BGP EVPN. Second, you modified the iBGP distance in Leaf-02, so routes advertised in BGP are preferred over OSPF. OSPF’s AD is 110, and BGP is 200. I’ve lowered the BGP distance to 90, so it is preferred over OSPF. Let’s validate route 10.100.10.0/24 in Leaf-02 (see Figure 5-15).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig15_HTML.jpg
Figure 5-15

Modifying the iBGP distance to a value less than the default OSPF distance will make iBGP a preferred route over OSPF

Yes, you can confirm that tenant-A on Leaf-02 prefers to send any request destined for 10.100.10.0/24 via the L3VNI to Leaf-01 VTEP 10.10.10.10 Now you need to make sure that all the other leafs in the VXLAN fabric are following the same path. You need to modify each tenant VRF distance in BGP to be the same as Leaf-01 or a lower number than the default OSPF AD of 110. In my case, I changed iBGP from 200 to 90 as the administrative distance. Apply on all leafs to select iBGP as a preferred route over OSPF. Why do you still need to do this if you don’t have OSPF adjacency on the other leafs? iBGP is always preferred for consistency, regardless of other route protocols. Apply the following configuration to the remaining leafs.
router bgp 65501
vrf Tenant-A
    address-family ipv4 unicast
      advertise l2vpn evpn
      distance 20 90 220
Let’s apply it on Leaf-03 and confirm that the distance change is now reflected on the tenant-A VRF routes (see Figure 5-16).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig16_HTML.jpg
Figure 5-16

You can confirm that after applying the config under Leaf-03, the preference for iBGP routes has changed to 90. It provides a consistent route path through the VXLAN fabric

Dynamic Routing Protocols Under VRFs

Working with multitenant environments can bring a level of complexity that can make any network engineer frightened. It is why you must build every environment with consistency. Something as simple as your naming scheme can make a big difference when troubleshooting needs to happen. When you decide to peer VXLAN tenants to an external network using dynamic routing protocols like BGP, OSPF, EIGRP, or IS-IS, it can become quite a challenge to maintain consistency due to the number of extra configurations required to accomplish it.

Let’s say you have a tenant called Italy, and another tenant called France. They both run services and host applications using your VXLAN fabric as a data transport. You want to have both tenants completely isolated. That’s the sole reason for multitenancy. But also, all the relevant operational processes for each tenant should be isolated. Italy has requested to peer their tenant to an external MPLS network.

The service provider has provisioned a demarcation for this circuit, and it’s ready to peer to the tenant on the fabric. The CE (customer edge) router holding the MPLS boundary is going to exchange routes using eBGP. The Italy network needs to reach the Italy tenant. You need to peer them to their MPLS using eBGP.

On the other side, France needs to peer its remote offices to their tenants on the fabric using OSPF. France has provided a router awaiting to establish an OSPF neighbor relationship.

You need to fulfill the request from both customers and make sure that other tenants aren’t affected by this change. Remember its multitenant environment. You might have more than ten tenants using your fabric to run their hosted servers and applications. You don’t want to disrupt any other tenant. You need to plan the configurations ahead of time and validate them to be 100 percent confident during the implementation.

The first thing you do is gather the information provided by the customer. From this information, you can then build the configuration script to be applied to the border leafs. Please find the information provided by the customer to fulfill the request.

Tenant: Italy

The following is the Italy tenant’s peer information.
  • MPLS L3VPN Router Interface: Gi0/1

  • MPLS L3VPN Router Interface IP: 145.11.24.25

  • MPLS L3VPN Router Interface Subnet 145.11.24.24/30

  • Italy MPLS eBGP AS: 43321

  • Italy VXLAN tenant BGP AS: 54423

  • Networks announced from the MPLS cloud
    • 172.21.10.0/24

    • 172.21.20.0/24

    • 172.21.30.0/24

You need to perform this configuration to receive the MPLS subnets on the Italy tenant VRF route table. The ISP informed that if you peer to them using private AS numbers, you won’t have an AS path or network reachability since those AS numbers are already in use in other locations.

Now that you have all the information you need, let’s enable BGP and OSPF under the tenants and allow connectivity to the external networks. Let’s begin configuring the connection for Italy’s tenant. Then you do the same for France. Please refer to the diagram in Figure 5-17 for the logical connectivity to the external sites.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig17_HTML.jpg
Figure 5-17

A tenant to carrier connectivity diagram. The Italy MPLS peers to the border leaf

When you enable tenants with dynamic routing protocols, you need to designate either an existing routing process or create a new one per tenant. I prefer to work with independent routing processes because if there is an issue with one process, the other tenants aren’t impacted.

You already have BGP running for the VXLAN EVPN address family. You need to configure a BGP IPv4 address family for the Italy tenant. You need to add a unique BGP AS number for the Italy tenant. You need to use the same AS number to peer the tenants. That might be an issue since you don’t control what tenants assign to their BGP community from AS number perspective. Instead, allow them as or override the AS number, so you don’t have conflicts with any other possible BGP neighbor in the AS path using the same number.

Enabling BGP for a Tenant VRF

To enable BGP in a VRF, you need to add the VRF under the global BGP router process. Add the BGP neighbor and inform BGP to use an interface to source the hello message. You want to use the layer 3 interface that faces the MPLS router. Next, enable the AFI that you are working with. In our case, it is IPv4 unicast. With the information provided by the service provider, you need to establish adjacency to the MPLS router, which is connected to DC1-N9500-Leaf-01. Let’s use the information provided and perform the configurations.

Listing 5-9 shows the Italy tenant BGP configuration on Leaf-01.
int eth1/6
no switchport
vrf member Italy
ip address 145.11.24.26/30
no shut
Router BGP 65501
  vrf Italy
    router-id 145.11.24.26
    address-family ipv4 unicast
    neighbor 145.11.24.25
      remote-as 43321
      local-as 54423
      update-source Ethernet1/6
      address-family ipv4 unicast
Listing 5-9

Italy Tenant BGP Configuration on Leaf-01

Now let’s do the verifications. You want to first confirm that there is a BGP neighbor adjacency with the MPLS router. To perform this check, type in Leaf-01, as follows. It is illustrated it Figure 5-18.
show bgp ipv4 unicast summary vrf Italy
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig18_HTML.jpg
Figure 5-18

A BGP adjacency to an external router in the tenant has been confirmed

You can confirm adjacency to the MPLS network. The show command output indicates a neighbor of 145.11.24.25, which is the BGP router ID for the MPLS router. You also have received three prefixes if you look at the State/PfxRcd column. That should give us an indication that the remote networks are advertised on the Italy VRF route table. Let’s confirm with the following command. It is illustrated it Figure 5-19.
 show ip route vrf Italy
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig19_HTML.jpg
Figure 5-19

Routes have been learned in the tenant from the external MPLS router once BGP adjacency is established

The MPLS routes are advertised in the Italy tenant VRF, but you need to make sure that the routes are available across all leafs. If the L3VNI is properly configured and assigned to the Italy tenant, you should have the routes across the VXLAN fabric. Let’s confirm if you see the routes in Leaf-03 (see Figure 5-20).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig20_HTML.jpg
Figure 5-20

The L3VNI interface in Leaf-03 is receiving the routes from Leaf-01 as EVPN route redistribution

Amazing. EVPN is doing its job. The MPLS networks are distributed in L3VNI to the other leafs. The next hop is the VTEP IP for Leaf-01.

Enabling OSPF for a Tenant VRF

Enabling OSPF for a tenant VRF is quite similar to BGP. The only difference with OSPF is that you can create a new OSPF router process and assign it to the tenant. In BGP, you only run a single BGP process. Once you create the OSPF process, you add the tenant VRF under it and configure your OSPF router ID. Here’s the catch. With BGP, you don’t have to redistribute the external networks so EVPN can re-advertise to all my leafs. In OSPF, you need to perform redistribution to announce the networks to the tenant in all leafs. Okay, let’s tackle the request to peer OSPF for the France tenant.

The diagram in Figure 5-21 should help you understand the connectivity layout for both sites. Site 1 router is homed to Leaf-01 via eth1/5. The site 2 router is homed to Leaf-02 via eth1/5. To be successful, all fabric leafs need to have advertised site 1 and site 2 networks in the France tenant VRF.
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig21_HTML.jpg
Figure 5-21

A multitenant VXLAN fabric peered with OSPF and BGP to external neighbors. The tenants are completely unaware of each other’s networks

Tenant: France

The following is the France tenant’s peer information.
  • Site 1 – OSPF Area 0

  • Site 1 Router Interface IP 172.16.1.1

  • Site 1 Router Interface Subnet 172.16.1.0/30

  • Site 2 – OSPF Area 1

  • Site 2 Router Interface IP 172.16.2.1

  • Site 2 Router Interface Subnet 172.16.2.0/30

  • Networks received via OSPF from site 1
    • 172.21.10.0/24

    • 172.21.20.0/24

    • 172.21.30.0/24

  • Networks received via OSPF from site 2
    • 172.22.10.0/24

    • 172.22.20.0/24

    • 172.22.30.0/24

Listing 5-10 shows the France tenant OSPF configuration on Leaf-01.
Router ospf France
 vrf France
  router-id 172.16.1.2
Int eth1/5
 no shut
 vrf member France
  ip address 172.16.1.2/30
  ip router ospf France area 0
  ip ospf network point-to-point
! Redistribute OSPF to BGP for Tenant France
route-map France-OSPF permit 10
  match route-type internal external type-1 type-2
router bgp 65501
 vrf France
  address-family ipv4 unicast
   redistribute ospf France route-map France-OSPF
Listing 5-10

France Tenant OSPF Configuration on Leaf-01

Let’s apply the configurations to both Leaf-01 and Leaf-02 and verify if you are successfully receiving routes from site 1 and site 2. Let’s confirm that you see the routes in the border leaf by using the following command. Then you should also see all the other leafs via EVPN (see Figure 5-22).
show ip ospf neighbors vrf France
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig22_HTML.jpg
Figure 5-22

Site 1 to France tenant OSPF neighbor in Leaf-01

You have established full OSPF adjacency to site 1’s router 172.16.1.1. Now let’s confirm if the routes were received from the site 1 router in the France tenant on Leaf-01 using the following command (see Figure 5-23).
show ip route vrf France
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig23_HTML.jpg
Figure 5-23

The routes in the France tenant are available via OSPF

You learned the routes from site 1 in the France tenant on the border leaf. Now you also performed a route redistribution from OSPF to BGP. You should have the routes learned fabric wide in the France tenant. Let’s verify on Leaf-03 to confirm if this is the case using the following command (see Figure 5-24).
show ip route vrf France
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig24_HTML.jpg
Figure 5-24

The routes from the tenant France on Leaf-01 are advertised via EVPN to the rest of the fabric. Leaf-03 has received the routes via the France VRF L3VNI

Site 1 has been fully integrated into the VXLAN fabric. You have confirmed adjacency and route redistribution to all leafs. Let’s do the same now for site 2, which connects to Leaf-02 (see Listing 5-11).
Router ospf France
 vrf France
  router-id 172.16.2.2
Int eth1/5
 No switchport
 no shut
 vrf member France
  ip address 172.16.2.2/30
  ip router ospf France area 1
  ip ospf network point-to-point
! Redistribute OSPF to BGP for Tenant France
route-map France-OSPF permit 10
  match route-type internal external type-1 type-2
router bgp 65501
 vrf France
  address-family ipv4 unicast
   redistribute ospf France route-map France-OSPF
Listing 5-11

France Tenant OSPF Configuration on Leaf-02

Now that you applied the configurations on Leaf-02, let’s confirm if you are receiving the routes from site 2. But first, using the following command, let’s make sure that there is OSPF adjacency to site 2 (see Figure 5-25).
show ip ospf neighbors vrf France
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig25_HTML.jpg
Figure 5-25

Site 2 to France tenant OSPF neighbor in Leaf-02

After confirming OSPF adjacency to site 2 via Leaf-02 on the France tenant, let’s verify if the routes were received from site 2 by using the following command (see Figure 5-26).
show ip route ospf-France vrf France
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig26_HTML.jpg
Figure 5-26

We can confirm that the OSPF routes in Leaf-02 are received from the site 2 router

Yes, routes are being received from site 2 to the France tenant. Finally, since you performed route redistribution from OSPF to BGP, let’s confirm that other leafs have received the routes via Leaf-02 L3VNI in EVPN.

Let’s confirm in Leaf-03 (see Figure 5-27).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig27_HTML.jpg
Figure 5-27

The routes learned via Leaf-02 are successfully advertised in EVPN to the other leafs in the fabric

Excellent! You can confirm that you have the routes from site 1 via EVPN to the L3VNI for Leaf-01 (10.10.10.10) and the routes from site 2 via EVPN to for Leaf-02’s L3VNI. The France tenant has end-to-end reachability to both sites across the entire VXLAN fabric. Success!

Default-Route Advertisement

How do you manage a default route in VXLAN BGP EVPN? In traditional campus networks, you usually have a border router or firewall connected to the edge of your network. When it comes to a spine-and-leaf topology, you usually connect this edge device between two leafs. You either statically assign a default route on those two leafs, or you get a default-route dynamically advertised from the edge device itself. But what about the other leafs. Do they also get it? No, unless you perform a default originate in the BGP IPv4 unicast address family on the tenant that receives it.

This section is about redistributing or re-advertising a default route in VXLAN BGP EVPN across the fabric for a tenant. Taking advantage of the previous exercise, let’s work with the same topology. Both France and Italy have requested to send all Internet-bound traffic via their remote networks. Italy would like to send from the tenant, traffic to the Internet via the MPLS circuit. France would like to send all Internet traffic to site 2. Let’s make sure that the default gateway is available across the Italy and France tenants’ fabric.

You should already have a default route on Leaf-01 for the Italy tenant, since Leaf-01 is connected to the MPLS router and should receive the route via BGP (see Figure 5-28).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig28_HTML.jpg
Figure 5-28

Italy tenant Leaf-01 route table

You can confirm that you are receiving the default route from the MPLS router. Now let’s confirm if the route was redistributed to all the other leafs (see Figure 5-29).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig29_HTML.jpg
Figure 5-29

The default route has been learned from Leaf-01 in EVPN. The rest of the fabric will use this route as last resort thru the L3VNI

Yes, the route has been redistributed. If you want to redistribute this route to another external network from the fabric—simple from the leaf that connects to the external network you need to perform the following BGP configuration.
Router bgp 65501
 vrf Italy
 address-family ipv4 unicast
  default-information originate
  network 0.0.0.0/0

There are two important commands. The default-information originate command tells the routing protocol to advertise a default route in its process. By adding this command to a static default route, you tell the process to redistribute the default route via its neighbors. The second command is network 0.0.0.0/0. In BGP, redistributing a default route is much more than the default-originate command. BGP expects a network statement of the default route, which is 0.0.0.0/0; otherwise, it does not advertise it.

Let’s now work with the France tenant. In Leaf-02 in the France tenant, you should already see a default route learned via OSPF. Let’s confirm it (see Figure 5-30).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig30_HTML.jpg
Figure 5-30

France tenant Leaf-02 route table

You have the default route injected from site 2 via OSPF in Leaf-02. But let’s check on Leaf-03 to see if the same default route was advertised (see Figure 5-31).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig31_HTML.jpg
Figure 5-31

An additional configuration is required under BGP to readvertise a default route to all peer routers or in this case Leafs

There is a problem. You don’t have the default route redistributed to BGP. While you can see the routes from site 2 networks, you can’t see the default route redistributed. Let’s fix it! You need to add the same commands I showed you from the Italy tenant to the BGP process in the France VRF. It needs to be done on the border leaf that you got from the default route advertised on site 2.
Router bgp 65501
 vrf France
 address-family ipv4 unicast
  default-information originate
  network 0.0.0.0/0
After applying the configurations, let’s verify Leaf-03 once again (see Figure 5-32).
../images/504299_1_En_5_Chapter/504299_1_En_5_Fig32_HTML.jpg
Figure 5-32

After applying the configuration changes we can confirm a successful default route advertisement in BGP

Success! You have redistributed the default route from site 2 to all leafs in the France tenant. Mission accomplished!

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.144.97.189