System Recovery to Local Tape Drive with make_tape_recovery

Ignite-UX is a product bundled with HP-UX 11i that provides a process to create a bootable system recovery tape. The tape contains a boot area and an operating system archive. Should your root disk fail or corruption of the root disk take place, you can recover using the bootable system recovery tape.

make_tape_recovery is the Ignite-UX tool that is used to create the bootable system recovery tape. You could boot and restore from the system recovery tape and then use your system backup to fully restore the system. If your root disk were to fail, in a non-mirrored environment, you would perform the following steps to recover from the failure:

  • Replace the defective root disk.

  • Boot from the recovery tape by selecting the tape device.

  • Monitor the restoration of the operating system archive from the recovery tape.

  • Restore the balance of data on the system with backup information.

The bootable system recovery tape consists of both a Logical Interchange Format (LIF) volume as well as the operating system archive. The LIF volume contains all the components necessary to boot from the tape. The operating system archive contains only the core operating system by default. The following bullet lists describe the components contained in the respective areas of the tape:

Boot and Configruation Files:

  • Boot files including ISL, HPUX, AUTO

  • System configuration information such as hostname, IP address, disk layout, and so on.

  • Ignite-UX kernel and user interface.

Archive Information includes one of the following three:

  • Minimum Core-OS to boot such as /sbin, /dev, /stand, /etc, /usr/bin, /usr/lib, /bin, /lib, /etc, and so on.

  • Entire root volume group.

  • Files from both root and non-root volume groups.

You can easily include additional information to be placed in the archive as well as preview what processing will take place. The following is a summary of the make_tape_recovery command:

/opt/ignite/bin/make_tape_recovery [ -s Ignite-UX_server ]
  [-a tape_drive] [-A] [-b] [-B boot_destination_file]
  [-d description] [-f content_file] [-i|-ib] [-I] [-l lanic_id]
  [-n num_cfg_dirs] [-p] [-P s|w|e] [-r] [-t tape_title_string]
  [-v] [-x content-options] [XToolkit_Options]

We'll use some of these options in our upcoming command line example. The following list shows the options you would use to add to or exclude from the archive:

Adding to or excluding from an archive:

  • -x include=<file|directory>

  • -x inc_cross=<file|directory> (this can contain any number of include, exclude, inc_entire, and inc_cross options.

  • -x exclude=<file|directory>

  • -x inc_entire=<vgname>|/dev/dsk/<name>

  • -f <contents_file>

  • -A (archive all volume groups that contain essential files)

You include information in the archive with -x include and exclude with -x exclude except for essential files which can't be excluded. -x inc_cross includes a file or directory recursively and crosses mount points. -x inc_entire will include an entire volume or disk.

Let's now run make_tape_recovery on a system. We'll issue three commands in the following example. The first is bdf, so that we can see the two volume groups on the system we wish to include: vg00 and vg01. Next we'll run make_tape_recovery in preview mode with -p and include both volume groups. Lastly we'll resume making the tape with the -r option with verbose output specified with -v:

# bdf
Filesystem          kbytes    used   avail %used Mounted on
/dev/vg00/lvol3     204800   70942  125523   36% /
/dev/vg00/lvol1     299157   26222  243019   10% /stand
/dev/vg00/lvol8    2609152  140280 2315011    6% /var
/dev/vg00/lvol7    1056768  767093  271616   74% /usr
/dev/vg00/lvol5     204800    1368  190782    1% /tmp
/dev/vg00/lvol6    1056768  691086  342888   67% /opt
/dev/vg00/lvol4     512000    1234  478849    0% /home
/dev/vg01/lvol1    4096000    2104 3838035    0% /backup
# make_tape_recovery -x inc_entire=vg00 -x inc_entire=vg01 -p
       * Creating local directories for configuration files and archive.

=======  03/25/02 10:36:24 EST  Started make_tape_recovery. (Mon Mar 25
         10:36:24 EST 2002)
         @(#) Ignite-UX Revision B.3.5.89
         @(#) net_recovery (opt) $Revision: 10.565 $

       * Testing pax for needed patch
       * Passed pax tests.
       * Creating System Configuration.
       * /opt/ignite/bin/save_config -f
         /var/opt/ignite/recovery/2002-03-25,10:36/system_cfg vg00 vg01
       * Backing Up Volume Group /dev/vg00
       * /usr/sbin/vgcfgbackup /dev/vg00
Volume Group configuration for /dev/vg00 has been saved in /etc/lvmconf/vg00.conf
       * Creating Map Files for Volume Group /dev/vg00
       * /usr/sbin/vgexport -p -m /etc/lvmconf/vg00.mapfile /dev/vg00
vgexport: Volume group "/dev/vg00" is still active.

       * Backing Up Volume Group /dev/vg01
       * /usr/sbin/vgcfgbackup /dev/vg01
Volume Group configuration for /dev/vg01 has been saved in /etc/lvmconf/vg01.conf
       * Creating Map Files for Volume Group /dev/vg01
       * /usr/sbin/vgexport -p -m /etc/lvmconf/vg01.mapfile /dev/vg01
vgexport: Volume group "/dev/vg01" is still active.

       * Creating Control Configuration.
       * Creating Archive File List
       * Creating Archive Configuration
vxvm:vxprint: ERROR: IPC failure: Configuration daemon is not accessible

       * /opt/ignite/bin/make_arch_config -c
         /var/opt/ignite/recovery/2002-03-25,10:36/archive_cfg -g
         /var/opt/ignite/recovery/2002-03-25,10:36/flist -n 2002-03-25,10:36 -r
         64 -d Recovery Archive -t -i 1
       * Saving the information about archive to
         /var/opt/ignite/recovery/previews
       *

       * **** This is just Preview Only.                        ****
       * **** No archive has been created yet.                  ****
       * **** You may modify the configure files                ****
       * **** and use -r option for resuming to create archive. ****


=======  03/25/02 10:37:02 EST  make_tape_recovery completed successfully!
# make_tape_recovery -r -v
NOTE:    ******* RESUMING *******
NOTE:    archive size: 1841410 kB
NOTE:    last preview is on 2002-03-25,10:36
NOTE:    The archive name is 2002-03-25,10:36
NOTE:    The archive description Recovery Archive
NOTE:    The archive is on local tape drive /dev/rmt/0mn
NOTE:    You want to resume archive creation from the configuration files
         locally on this system.
NOTE:    In Resume Mode.  Do you wish to continue?
Continue?(y/n)y
       * Creating The Tape Archive
       * Checking configuration file for Syntax
       * Writing boot LIF to tape
30000+1 records in
30000+1 records out
       * Complete writing boot LIF onto tape.
       * /opt/ignite/data/scripts/make_sys_image -c n -d /dev/rmt/0mn -t n -s
         local -n 2002-03-25,10:36 -m t -w
         /var/opt/ignite/recovery/latest/recovery.log -u -R -g
        /var/opt/ignite/recovery/latest/flist -a 1841410             * Creation of system
 archive complete
       * Preparing to create a system archive
NOTE: Could not read the /etc/resolv.conf file.
     * Archiving contents of mponiatowsk4457 via tar image to local device/dev/rmt/0mn.
=======  03/25/02 10:59:42 EST  make_tape_recovery completed successfully!
#

When we resume the make_tape_recovery, the process of creating the bootable archive tape completes. The LIF area is first written to the tape, then all of the information from the two volume groups is included. You can see that the make_sys_image script is called after the LIF area is written to the tape.

Both volume groups were active at the time this tape archive was produced; however, there was minimal activity on the system.

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.134.100.31