Case Study: Configuring Static Routes and Routing Protocols with Cisco

Complete the following exercises by configuring static routes and routing protocols with IPv6 to practice the skills you learned in this chapter.

Objectives

In this exercise, you will complete the following tasks:

  • Configuring a static IPv6 route on a router

  • Configuring a default IPv6 route

  • Verifying an IPv6 route table

  • Enabling BGP4+ for IPv6

  • Establishing eBGP peerings using an aggregatable global unicast IPv6 address

  • Displaying BGP IPv6 neighbors

  • Statically configuring an aggregatable global unicast IPv6 address

  • Statically configuring a link-local address

  • Establishing iBGP peering using a link-local address

  • Creating a route map for IPv6

Commands List

In this configuration exercise, you will use the commands shown in Table 4-16. If necessary, refer to this list during the exercise.

Table 4-16. Commands List
CommandDescription
address-family ipv6Enters the address-family ipv6 subcommand mode of a router configuration.
copy run startSaves the current configuration to NVRAM.
ipv6 unicast-routingEnables IPv6 traffic forwarding.
ipv6 address 3ffe:b00:ffff:1::2/64Configures a static IPv6 address.
ipv6 address 2001:410:ffff:1::2/64Configures a static IPv6 address.
ipv6 address 2001:430:ffff:1::1/64Configures a static IPv6 address.
ipv6 address fe80::1001 link-localConfigures a static IPv6 address. This is a link-local address.
ipv6 route 3ffe::/16 fastethernet0/0 fe80::260:3eff:fe47:1533Configures a static IPv6 route pointing out a link-local address as the next hop.
ipv6 route::/0 fastethernet0/1 fe80::260:3eff:fe78:3351Configures a default IPv6 route pointing out a link-local address as the next hop.
ipv6 nd suppress-raSuppresses router advertisement.
neighbor 2001:410:ffff:1::1 remote-as 65099Configures BGP peering using an IPv6 address.
neighbor 2001:410:ffff:1::1 activateActivates BGP peering.
network 2001:430:ffff::/48Specifies the prefix 2001:430:ffff::/48 to announce via a routing protocol.
no bgp default ipv4-unicastDisables the advertisement of BGP-4 routing information for the IPv4 address family.
router bgp 65005Enables the BGP4+ router process for the AS65005.
route-map linklocal-iBGPDefines a route map.
set ipv6 next-hop 2001:430:ffff:1::1Sets the NEXT_HOP attribute.
show ipv6 interface fastEthernet 0/0Displays the IPv6 configuration applied to an interface.
show ipv6 interface fastethernet 0/1Displays the IPv6 configuration applied to an interface.
show bgp ipv6 neighborsDisplays information on the state of all IPv6 BGP4+ neighbors.

Task 1: Configure Static and Default Routes on a Router

Figure 4-11 shows the network architecture used in Task 1. Your corporate network is getting IPv6 connectivity to the IPv6 Internet through the IPv6 provider using 2001:410::/35 as an aggregatable global unicast network prefix. The IPv6 provider assigned the prefix 2001:410:ffff::/48 to your corporate network. However, your corporate network is also connected to the 6bone network, which is based on the aggregatable global unicast prefix 3ffe::/16. The main goal of this task is to set on Router R4 a static IPv6 route for the prefix 3ffe::/16 that points out the 6bone and then add a default IPv6 route pointing out the IPv6 provider.

Figure 4-11. Adding Static IPv6 Routes on a Router


Complete the following steps:

Step 1.
Enter the command to enable IPv6 traffic forwarding on Router R4 to forward unicast IPv6 packets between interfaces. What command should you use?

RouterR4#conf t
RouterR4(config)#ipv6 unicast-routing
RouterR4(config)#exit
								

Step 2.
Based on the following table, assign one static IPv6 address to each interface of Router R4 specified. Then disable router advertisement on each interface. What command assigns a static IPv6 to an interface?

Router R4 InterfaceIPv6 Address
FastEthernet 0/0 (FE0/0)3ffe:b00:ffff:1::2/64
FastEthernet 0/1 (FE0/1)2001:410:ffff:1::2/64

RouterR4#conf t
RouterR4(config)#int fe0/0
RouterR4(config-if)#ipv6 address 3ffe:b00:ffff:1::2/64
RouterR4(config-if)#ipv6 nd suppress-ra
RouterR4(config-if)#int fe0/1
RouterR4(config-if)#ipv6 address 2001:410:ffff:1::2/64
RouterR4(config-if)#ipv6 nd suppress-ra
RouterR4(config-if)#exit
RouterR4(config)#exit
								

Step 3.
Verify the static IPv6 addresses of each interface. What command displays IPv6 addresses used on an interface?

RouterR4#show ipv6 interface fastEthernet 0/0
RouterR4#show ipv6 interface fastEthernet 0/1
								

Step 4.
Configure a static IPv6 route on Router R4 to reach the destination network 3ffe::/16, represented in Figure 4-11 as the 6bone. Use the next-hop link-local address fe80::260:3eff:fe47:1533 through the FastEthernet0/0 interface. What command will you use?

RouterR4#conf t
RouterR4(config)#ipv6 route 3ffe::/16 fastethernet0/0 fe80::260:3eff:fe47:1533
RouterR4(config)#exit
								

Step 5.
Configure a default IPv6 route to reach the IPv6 Internet through the FastEthernet0/1 interface. Use the next-hop link-local address fe80::260:3eff:fe78:3351.

RouterR4#conf t
RouterR4(config)#ipv6 route ::/0 fastethernet0/1 fe80::260:3eff:fe78:3351
RouterR4(config)#exit
								

Step 6.
Examine the current IPv6 routing table in Router R4 and verify the static and default IPv6 routes added. What command is used to display the IPv6 routes?

RouterR4#show ipv6 route
								

Step 7.
Save the current configuration to NVRAM.

RouterR4#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

Task 2: Configure eBGP and iBGP Peerings on Router R2

Figure 4-12 shows the network architecture used for Task 2. Your domain is AS65005, and you have to configure multihop eBGP peering with AS65099 and AS65123 on border Router R2 using the aggregatable global unicast IPv6 addresses of your neighbors. Then, because routers R1 and R2 are adjacent on the same link, you have to configure an iBGP peering with Router R1 but using the link-local address of this iBGP neighbor.

Figure 4-12. Configuring eBGP and iBGP Peerings


Follow these steps:

Step 1.
Before establishing the eBGP peering with AS65009 and AS65123, add two IPv6 static routes on Router R2 to reach these domains. The destination prefix 2001:410:ffff::/48 can be reached using the next-hop link-local address fe80::260:3eff:fe58:2644. The destination prefix 2001:420:ffff::/48 can be reached through the next-hop link-local address fe80::260:3eff:fe89:4462. What commands will you use to perform these tasks?

RouterR2#conf t
RouterR2(config)#ipv6 route 2001:410:ffff::/48 ethernet1 fe80::260:3eff:fe58:2644
RouterR2(config)#ipv6 route 2001:420:ffff::/48 ethernet1 fe80::260:3eff:fe89:4462
RouterR2(config)#exit
								

Step 2.
Enter the command to enable a BGP4+ router process on Router R2 for the AS65005. What command will you use?

RouterR2#conf t
RouterR2(config)#router bgp 65005
RouterR2(config-router)#

Step 3.
Disable the advertisement of routing information for the IPv4 address family on the BGP router process. Also define the router ID as 172.16.1.1.

RouterR2(config-router)#no bgp default ipv4-unicast
RouterR2(config-router)#bgp router-id 172.16.1.1
RouterR2(config-router)#

Step 4.
Specify the IPv6 prefix of this AS to announce via BGP4+. The IPv6 prefix of this AS is 2001:430:ffff::/48. What command will you use?

RouterR2(config-router)#address-family ipv6
RouterR2(config-router-af)#network 2001:430:ffff::/48
RouterR2(config-router-af)#exit
RouterR2(config-router)#exit
								

Step 5.
Configure the BGP peering with AS65099. Use the aggregatable global unicast IPv6 address 2001:410:ffff:1::1 to establish this BGP peering. Be sure BGP peering is activated. What commands configure BGP peering with a neighbor?

RouterR2(config-router)#neighbor 2001:410:ffff:1::1 remote-as 65099
RouterR2(config-router)#address-family ipv6
RouterR2(config-router-af)#neighbor 2001:410:ffff:1::1 activate
RouterR2(config-router-af)#exit
RouterR2(config-router)#

Step 6.
As you did in Step 5, configure BGP4+ peering with AS65123, but use the aggregatable global unicast IPv6 address 2001:420:ffff:2::1.

RouterR2(config-router)#neighbor 2001:420:ffff:2::1 remote-as 65123
RouterR2(config-router)#address-family ipv6
RouterR2(config-router-af)#neighbor 2001:420:ffff:2::1 activate
RouterR2(config-router-af)#exit
RouterR2(config-router)#exit
								

Step 7.
Verify your BGP4+ configuration by displaying information on the state of the IPv6 BGP4+ neighbors. What command configures BGP peering with a neighbor?

RouterR2#show bgp ipv6 neighbors
								

Step 8.
Using the following table, statically assign one aggregatable global unicast and one link-local IPv6 address to Router R2's Ethernet0 interface. The Ethernet0 interface will be used to configure iBGP peering using the link-local address of the adjacent BGP4+ neighbor.

Type of AddressIPv6 Address
Link-local addressfe80::1001
Global IPv6 address2001:430:ffff:1::1/64

RouterR2#conf t
RouterR2(config)#int ethernet0
RouterR2(config-if)#ipv6 address 2001:430:ffff:1::1/64
RouterR2(config-if)#ipv6 address fe80::1001 link-local
RouterR2(config-if)#exit
RouterR2(config)#exit
RouterR2#

Step 9.
Define a route-map statement to set the NEXT_HOP attribute on outbound BGP4+ updates to be sent to the iBGP neighbor (Router R1). The NEXT_HOP attribute must be set to the IPv6 address 2001:430:ffff:1::1.

RouterR2#conf t
RouterR2(config)#route-map linklocal-iBGP
RouterR2(config-route-map)#set ipv6 next-hop 2001:430:ffff:1::1
RouterR2(config-route-map)#exit
RouterR2(config)#

Step 10.
Configure iBGP peering on Router R2 with Router R1. Use Router R1's link-local address fe80::1002 in the BGP4+ configuration.

RouterR2(config)#router bgp 65005
RouterR2(config-router)#neighbor fe80::1002 remote-as 65005
RouterR2(config-router)#neighbor fe80::1002 update-source ethernet0
RouterR2(config-router)#address-family ipv6
RouterR2(config-router-af)#neighbor fe80::1002 activate
RouterR2(config-router-af)#neighbor fe80::1002 route-map linklocal-iBGP out
RouterR2(config-router-af)#exit-address-family
RouterR2(config-router)#

Step 11.
Examine again your BGP4+ configuration by displaying information on the state of all IPv6 BGP4+ neighbors. You should see the new iBGP peering using a link-local address.

RouterR2#show bgp ipv6 neighbors
								

Step 12.
Save the current configuration to NVRAM.

RouterR2#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.19.217.29