Case Study: Internetworking IPv6 Hosts with Cisco

Complete the following exercises to practice the skills you learned in this chapter. You will configure Solaris, Windows, and FreeBSD with IPv6 support to interact with a Cisco router.

Objectives

In the following exercises, you will complete these tasks:

  • Enabling IPv6 and stateless autoconfiguration on the network interfaces on Cisco

  • Assigning static IPv6 addresses to interfaces of a Cisco router

  • Turning off router advertisement on Cisco

  • Adding a default IPv6 route on Cisco

  • Enabling stateless autoconfiguration on Solaris

  • Assigning a static IPv6 address to an interface and adding a default IPv6 router on Solaris

  • Enabling and setting a configured tunnel interface on Cisco

  • Enabling and setting 6to4 support on Cisco

  • Adding a static IPv6 route for 6to4 on Cisco

  • Enabling the 6to4 mechanism on Windows XP

  • Establishing a configured tunnel on FreeBSD

  • Verifying interfaces, addresses, and routes on Cisco, Solaris, Windows, and FreeBSD

Commands List

You will use the Cisco IOS Software commands shown in Table 6-8 in the exercises.

Table 6-8. Commands List
CommandDescription
copy run startSaves the current configuration to NVRAM.
ipv6 unicast-routingEnables IPv6 traffic forwarding.
ipv6 address 2001:410:ffff:0::1/64Configures a static IPv6 address.
ipv6 address 2001:410:ffff:1::1/64Configures a static IPv6 address.
ipv6 address 2001:410:ffff:2::1/64Configures a static IPv6 address.
ipv6 address 2001:410:ffff:9::1/64Configures a static IPv6 address.
ipv6 address 2002:ce7b:1f02:1::1/64Configures a static IPv6 address.
ipv6 unnumbered ethernet0Instructs an interface to use the IPv6 address of another interface as a source address.
ipv6 route 2002::/16 tunnel5Configures a static IPv6 route that points to the tunnel5 interface.
ipv6 route::/0 2001:410:ffff:0::2Configures a default IPv6 route.
ipv6 nd suppress-raSuppresses router advertisement.
show ip interface ethernet0Displays the IPv4 configuration applied to an interface.
show ipv6 interface ethernet1Displays the IPv6 configuration applied to an interface.
show ipv6 interface fastEthernet 0/0Displays the IPv6 configuration applied to an interface.
show ipv6 interface fastethernet 0/1Displays the IPv6 configuration applied to an interface.
show ipv6 routeDisplays the IPv6 routing table.
tunnel mode ipv6ipDefines the tunnel interface as a configured tunnel.
tunnel mode 6to4Defines the tunnel interface as the 6to4 tunnel.
tunnel source ethernet0Specifies an interface with an IPv4 address assigned.
tunnel source 206.123.31.3Assigns the IPv4 source address to a configured tunnel interface.
tunnel destination 67.68.100.43Assigns the IPv4 destination address to a configured tunnel interface.

Network Architecture for the Configuration Exercise

Figure 6-14 shows the network architecture used in this case study. Your internal network contains Solaris, Windows 2000, and Windows XP nodes enabled with IPv6. They receive their IPv6 addresses from Router R1 on interface FE0/0 through stateless autoconfiguration. You must enable IPv6 on the hme0 interface of Solaris node A to perform stateless autoconfiguration on this node.

Figure 6-14. Adding Static IPv6 Routes on a Router


On interface FE0/1 of Router R1, a node based on Solaris with IPv6 support acts as an IPv6 web server. Because router advertisement is turned off on interface FE0/0, you will assign a static IPv6 address to Solaris's qfe0 interface.

Router R1 of your network is also connected to the IPv4 Internet and the IPv6 Internet using interfaces E0 and E1, respectively. You will enable and configure 6to4 support on the Windows XP node C, and then you will establish a configured tunnel between the FreeBSD node D and Router R1.

Task 1: Configure Network Interfaces on Router R1

To perform Task 1, use Table 6-9. It shows the assignment of addresses on network interfaces E0, E1, FE0/0, and FE0/1 for Router R1. The field RA represents the activation of router advertisement on the given interface. If the RA field is set to Y, be sure to turn on the given prefixes.

Table 6-9. Assignment of Addresses and Parameters for Router R1's Network Interfaces
InterfaceIPv4 AddressIPv6 AddressRAPrefix Advertised
E0206.123.31.2/24NoneNNone
E1None2001:410:ffff:0::1/64Y2001:410:ffff:0::/64
FE0/0None2001:410:ffff:2::1/64Y2001:410:ffff:2::/64
FE0/1None2001:410:ffff:1::1/64NNone

Complete the following steps:

Step 1.
Based on Table 6-9, assign the static IPv4 address 206.123.31.2/24 to interface E0 of Router R1. Following this task, add a default IPv4 route pointing to the next-hop IPv4 address 206.123.31.1 (the IPv4 Internet domain).

RouterR1(config)#interface ethernet0
RouterR1(config-if)#ip address 206.123.31.2 255.255.255.0
RouterR1(config-if)#exit
RouterR1(config)#ip route 0.0.0.0 0.0.0.0 206.123.31.1
RouterR1(config-if)#exit
								

Step 2.
Enter the command to enable IPv6 traffic forwarding on Router R1 to forward unicast IPv6 packets between all interfaces. What command will you use?

RouterR1#conf t
RouterR1(config)#ipv6 unicast-routing
RouterR1(config)#exit
								

Step 3.
Enable IPv6, assign the static IPv6 address 2001:410:ffff:0::1/64 to interface E1 of Router R1, and advertise the prefix 2001:410:ffff:0::/64 on the link. What command performs all these tasks?

RouterR1#conf t
RouterR1(config)#int ethernet1
RouterR1(config-if)#ipv6 address 2001:410:ffff:0::1/64
RouterR1(config-if)#exit
								

Step 4.
On interface FE0/0 of Router R1, enable IPv6, assign the static IPv6 address 2001:410:ffff:2::1/64, and advertise the prefix 2001:410:ffff:2::/64.

RouterR1#conf t
RouterR1(config)#int fastethernet 0/0
RouterR1(config-if)#ipv6 address 2001:410:ffff:2::1/64
RouterR1(config-if)#exit
								

Step 5.
Assign the IPv6 address 2001:410:ffff:1::1/64 to interface FE0/1 of Router R1. Then add the command to suppress the advertisement of the prefix 2001:410:ffff:1::/64 on interface FE0/1. Which commands will you use?

RouterR1#conf t
RouterR1(config)#int fastEthernet 0/1
RouterR1(config-if)#ipv6 address 2001:410:ffff:1::1/64
RouterR1(config-if)#ipv6 nd suppress-ra
RouterR1(config-if)#exit
								

Step 6.
Verify the IPv4 and IPv6 addresses assigned on each interface. What are the commands used to display IPv4 and IPv6 addresses assigned on interfaces?

RouterR1#show ip interface ethernet0
RouterR1#show ipv6 interface ethernet1
RouterR1#show ipv6 interface fastEthernet 0/0
RouterR1#show ipv6 interface fastEthernet 0/1
								

Step 7.
Configure a default IPv6 route pointing to the next-hop link-local address fe80::1001 (the IPv6 Internet). Which command will you use?

RouterR1#conf t
RouterR1(config)#ipv6 route ::/0 ethernet1 fe80::1001
RouterR1(config)#exit
								

Step 8.
Examine the current IPv6 routing table in Router R1 and verify the IPv6 routes. You should see a default IPv6 route. What is the command used to display the IPv6 routes?

RouterR1#show ipv6 route
								

Step 9.
Save the current configuration to NVRAM.

RouterR1#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

Task 2: Enable Stateless Autoconfiguration and Assign a Static IPv6 Address on Solaris

Complete the following steps:

Step 1.
Enable stateless autoconfiguration on the hme0 interface of Solaris node A as shown in Figure 6-14.

Solaris-nodeA#touch /etc/hostname6.hme0
Solaris-nodeA#reboot
								

Step 2.
After Solaris node A has rebooted, verify whether hme0 got one IPv6 address through stateless autoconfiguration. What command verifies the IPv6 addresses assigned to a specific interface on Solaris?

Solaris-nodeA#ifconfig hme0 inet6
								

Step 3.
Solaris node B, as shown in Figure 6-14, is acting as an IPv6 web server, and it needs a permanent IPv6 address. Therefore, on Solaris node B, assign the static IPv6 address 2001:410:ffff:1::10/64 to interface qfe0. Which command will you use to perform this task?

Solaris-nodeB#touch /etc/hostname6.hme0
Solaris-nodeB#reboot
...
Solaris-nodeB#ifconfig qfe0 inet6 addif 2001:410:ffff:1::10/64 up
								

Step 4.
Configure a default IPv6 route pointing to the next-hop IPv6 address 2001:410:ffff:1::1 (interface FE0/1 of Router R1). Which command will you use?

Solaris-nodeB#route add -inet6 default 2001:410:ffff:1::1
								

Step 5.
Verify the static IPv6 address assigned on the qfe0 interface and the default IPv6 route added. What commands are used?

Solaris-nodeB#ifconfig qfe0 inet6
Solaris-nodeB#netstat -rn
								

Task 3: Configure Tunnel Interfaces on Router R1

To perform Task 3, use Table 6-10. It shows the assignment of addresses for the tunnel interfaces on Router R1.

Table 6-10. Assignment of Addresses for the Tunnel Interfaces on Router R1
InterfaceTypeSource IPv4 AddressDestination IPv4 AddressSource IPv6 AddressDestination IPv6 address
Tunnel2Configured tunnel206.123.31.367.68.100.432001:410:ffff:9::1/642001:410:ffff:9::2/64
Tunnel56to4E0None2002:ce7b:1f02:1::1/64None

Complete the following steps:

Step 1.
Enable and set a configured tunnel with FreeBSD node D on the tunnel2 interface of Router R1. Use 206.123.31.3 as the source IPv4 address and 67.68.100.43 as the destination IPv4 address for the tunnel. Then assign 2001:410:ffff:9::1/64 as the source IPv6 address.

RouterR1#conf t
RouterR1(config)#interface tunnel2
RouterR1(config-if)#tunnel source 206.123.31.3
RouterR1(config-if)#tunnel destination 67.68.100.43
RouterR1(config-if)#ipv6 address 2001:410:ffff:9::1/64
RouterR1(config-if)#tunnel mode ipv6ip
RouterR1(config-if)#exit
RouterR1(config)#exit
								

Step 2.
Enable the 6to4 mechanism on Router R1. Begin with the assignment of the static IPv6 address 2002:ce7b:1f02:1::1/64 to the E0 interface. This address is within the 6to4 prefix 2002:ce7b:1f02::/48. The 6to4 prefix has been calculated using the public IPv4 address 206.123.31.2 of interface E0.

RouterR1#conf t
RouterR1(config)#int ethernet0
RouterR1(config-if)#ipv6 address 2002:ce7b:1f02:1::1/64
RouterR1(config-if)#exit
								

Step 3.
Enter the command to suppress the advertisement of the prefix 2002:ce7b:1f02:1::/64 on interface E0, because there is no reason to send router advertisement messages on this router's public interface.

RouterR1#conf t
RouterR1(config)#int ethernet0
RouterR1(config-if)#ipv6 nd suppress-ra
RouterR1(config-if)#exit
								

Step 4.
Enable the 6to4 router using the tunnel5 interface. Use the IPv4 and IPv6 addresses assigned to interface E0 as addresses for the 6to4 mechanism. What commands are used to enable 6to4 on a Cisco router?

RouterR1#conf t
RouterR1(config)#int tunnel5
RouterR1(config-if)#no ip address
RouterR1(config-if)#ipv6 unnumbered ethernet0
RouterR1(config-if)#tunnel source ethernet0
RouterR1(config-if)#tunnel mode ipv6ip 6to4
RouterR1(config-if)#exit
								

Step 5.
Because the 6to4 sites on the IPv4 Internet can be reached through the tunnel5 interface, add a route for the destination prefix 2002::/16 in Router R1 pointing out the interface tunnel5. What command will you use?

RouterR1#conf t
RouterR1(config)#ipv6 route 2002::/16 tunnel5
RouterR1(config)#exit
								

Step 6.
Verify the tunnel2 and tunnel5 interfaces on Router R1. What commands are used to display tunnel interface configurations?

RouterR1#show ipv6 interface tunnel2
RouterR1#show ipv6 interface tunnel5
								

Step 7.
Save the current configuration to NVRAM.

RouterR1#copy run start
Destination filename [startup-config]?
Building configuration...

Task 4: Enable 6to4 on Microsoft Windows XP

Complete the following steps:

Step 1.
On Windows XP, the interface assigned to the 6to4 mechanism is pseudo-interface 3. Enable the 6to4 mechanism on pseudo-interface 3 of Windows XP node C, as shown in Figure 6-14. For this task, the IPv4 address 69.10.100.41 is assigned to Windows XP node C. Assign the static IPv6 address 2002:450a:6429:1::1 to pseudo-interface 3.

C:ipv6.exe rtu 2002::/16 3
C:ipv6.exe adu 3/2002:450a:6429:1::1
								

Step 2.
Display the pseudo-interfaces list on Windows XP node C and verify the pseudo-interface 3 configuration. What command is used to display pseudo-interface lists?

C:ipv6.exe if
								

Task 5: Define a Configured Tunnel on FreeBSD

Complete the following steps:

Step 1.
Start the configuration by enabling the configured interface gif0 on FreeBSD node D as shown in Figure 6-14.

FreeBSD-nodeD#ifconfig gif0 create
								

Step 2.
After the configured interface is created, assign the source and destination IPv4 addresses to establish the tunnel. Use 67.68.100.43 as the source and 206.123.31.3 as the destination.

FreeBSD-nodeD#gifconfig gif0 67.68.100.43 206.123.31.3
								

Step 3.
Assign the static IPv6 addresses 2001:410:ffff:9::2 and 2001:410:ffff:9::1 to the endpoints of the configured tunnel. The address 2001:410:ffff:9::2 is the source address of FreeBSD node D.

FreeBSD-nodeD#ifconfig gif0 inet6 2001:410:ffff:9::2 2001:410:ffff:9::1
									prefixlen 128 alias
								

Step 4.
Configure a default IPv6 route pointing to the next-hop IPv6 address 2001:410:ffff:9::1 (the tunnel endpoint). What command will you use?

FreeBSD-nodeD#route add -inet6 default 2001:410:ffff:9::1
								

Step 5.
Verify the IPv4 and IPv6 addresses assigned on the gif0 interface and the default IPv6 route. What commands are used?

FreeBSD-nodeD#ifconfig gif0
FreeBSD-nodeD#netstat -f inet6 -rn
								

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.147.45.212