Day 18

Basic Router Configuration

CCNA 200-301 Exam Topics

  • Describe characteristics of network topology architectures

  • Identify interface and cable issues (collisions, errors, mismatch duplex and/or speed)

  • Configure and verify IPv4 addressing and subnetting

  • Configure and verify IPv6 addressing and prefix

Key Topics

Today we review basic router configuration. First, we focus on configuring and verifying initial settings, including IPv4 addressing. We look at the details of the show interface command to understand how it can help in identifying interface and cable issues. Then we review IPv6 addressing and network connectivity verification. Most of this should be very familiar at this point in your studies because these skills are fundamental to all other router configuration tasks. We also review small office or home office (SOHO) setup and configuration.

Basic Router Configuration with IPv4

Figure 18-1 shows the topology and IPv4 addressing scheme that we use today to review basic router configuration and verification tasks.

Figure 18-1 IPv4 Example Topology

When configuring a router, certain basic tasks are performed:

  • Naming the router

  • Setting passwords

  • Configuring interfaces

  • Configuring a banner

  • Saving changes on a router

  • Verifying basic configuration and router operations

Command Syntax

Table 18-1 shows the basic router configuration command syntax used to configure R1 in the following example.

Table 18-1 Basic Router Configuration Command Syntax

Configuration Task

Commands

Naming the router

Router(config)# hostname name

Setting passwords

Router(config)# enable secret password

Router(config)# line console 0

Router(config-line)# password password

Router(config-line)# login

Router(config)# line vty 0 15

Router(config-line)# transport input ssh

Router(config-line)# login local

Router(config)# username name password password

Configuring a message-of-the-day banner

Router(config)# banner motd # message #

Configuring an interface

Router(config)# interface type number

Router(config-if)# ip address address mask

Router(config-if)# description description

Router(config-if)# no shutdown

Saving changes on a router

Router# copy running-config startup-config

Examining the output of show commands

Router# show running-config

Router# show ip route

Router# show ip interface brief

Router# show interfaces

Configuration Example

Let’s walk through a basic configuration for R1. First, enter privileged EXEC mode and then global configuration mode:

Router> enable
Router# config t

Next, name the router and enter the encrypted password for entering privileged EXEC mode. This command overrides the older enable password password command, so you are not entering that one:

Router(config)# hostname R1
R1(config)# enable secret class

Next, configure the console password and require that it be entered with the login password:

R1(config)# line console 0
R1(config-line)# password cisco
R1(config-line)# login

Configuring SSH and disabling Telnet are security best practices, so configure the vty lines to use only SSH:

R1(config)# line vty 0 15
R1(config-line)# transport input ssh
R1(config-line)# login local
R1(config-line)# exit
R1(config)# username admin password cisco

Encrypt all the plaintext passwords in the running configuration by using the service-password encryption command:

R1(config)# service-password encryption

Configure the message-of-the-day (MOTD) banner. A delimiting character such as a # is used at both the beginning and the end of the message. At a minimum, a banner should warn against unauthorized access. A good security policy prohibits configuring a banner that welcomes an unauthorized user:

R1(config)# banner motd #
Enter TEXT message.    End with the character '#'.
******************************************
WARNING!! Unauthorized Access Prohibited!!
******************************************
#

Now configure the individual router interfaces with IP addresses and other information. First, enter interface configuration mode by specifying the interface type and number and then configure the IP address and subnet mask:

R1(config)# interface Serial0/0/0
R1(config-if)# ip address 192.168.2.1 255.255.255.0

It is good practice to configure a description on each interface to help document the network information:

R1(config-if)# description Ciruit#VBN32696-123 (help desk:1-800-555-1234)

Activate the interface:

R1(config-if)# no shutdown

Assuming that the other side of the link is activated on R2, the serial interface is now up. Finish R1 by configuring the GigabitEthernet 0/0 interface:

R1(config-if)# interface GigabitEthernet0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# description R1 LAN
R1(config-if)# no shutdown

Assume that R2 is fully configured and can route back to the 192.168.1.0/24 LAN attached to R1. You need to add a static route to R1 to ensure connectivity to R2’s LAN. Static routing is reviewed in more detail on Day 19, “Basic Routing Concepts.” For now, enter the following command to configure a directly attached static route to R2’s LAN:

R1(config)# ip route 192.168.3.0 255.255.255.0 Serial 0/0/0

To save the configuration, enter the copy running-config startup-config command or the copy run start command.

Verification Example

You can use the show running-config command to verify the full current configuration on the router. However, a few other basic commands can help you verify your configuration and also begin troubleshooting any potential problems.

Make sure that the networks for your interfaces are now in the routing table by using the show ip route command, as shown in Example 18-1.

Example 18-1 The show ip route Command

R1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
      + - replicated route, % - next hop override
Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C      192.168.1.0/24 is directly connected, GigabitEthernet0/0
L      192.168.1.1/32 is directly connected, GigabitEthernet0/0
    192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C      192.168.2.0/24 is directly connected, Serial0/0/0
L      192.168.2.1/32 is directly connected, Serial0/0/0
S   192.168.3.0/24 is directly connected, Serial0/0/0
R1#

If a network is missing, check your interface status with the show ip interface brief command, as shown in Example 18-2.

Example 18-2 The show ip interface brief Command

R1# show ip interface brief
Interface                   IP-Address   OK?   Method  Status Protocol
Embedded-Service-Engine0/0   unassigned YES unset administratively down down
GigabitEthernet0/0         192.168.1.1 YES manual up up
GigabitEthernet0/1         unassigned YES unset administratively downdown
Serial0/0/0               192.168.2.1 YES manual up up
Serial0/0/1               unassigned YES unset administrativelydown down
R1#

The output from the show ip interface brief command provides three important pieces of information:

  • IP address

  • Line status (column 5)

  • Protocol status (column 6)

The IP address should be correct, and the status codes should be up and up. Table 18-2 summarizes the two status codes and their meanings.

Table 18-2 Interface Status Codes

Code

Location

General Meaning

Line status

First status code

Refers to the Layer 1 status—for example, is the cable installed, is it the right/wrong cable, is the device on the other end powered on?

Protocol status

Second status code

Refers generally to the Layer 2 status. It is always down if the line status is down. If the line status is up, a protocol status of down is usually caused by mismatched data link layer configuration.

Four combinations of settings are possible for the status codes when troubleshooting a network. Table 18-3 lists the four combinations and explains the typical reasons an interface might be in that state.

Table 18-3 Combinations of Interface Status Codes

Line and Protocol Status

Typical Reason(s)

Administratively down, down

The interface has a shutdown command configured on it.

down, down

The interface has a no shutdown command configured, but the physical layer has a problem. For example, no cable has been attached to the interface (or with Ethernet), the switch interface on the other end of the cable is shut down, or the switch is powered off.

up, down

This almost always refers to data link layer problems, most often configuration problems. For example, serial links have this combination when one router was configured to use PPP and the other defaults to use HDLC.

However, a clocking or hardware issue can also be to blame.

up, up

All is well and the interface is functioning.

If necessary, use the more verbose show interface command if you need to track down a problem with an interface and get the output for every physical and virtual interface. You can also specify one interface. Example 18-3 shows the output for GigabitEthernet 0/0.

Example 18-3 The show interface gigabitethernet 0/0 Command

R1# show interface gigabitethernet 0/0
GigabitEthernet0/0 is up, line protocol is up
  Hardware is CN Gigabit Ethernet, address is 30f7.0da3.0da0 (bia 30f7.0da3.0da0)
  Description: R1 LAN
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full Duplex, 100Mbps, media type is RJ45
  output flow-control is unsupported, input flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
    387 packets input, 59897 bytes, 0 no buffer
     Received 252 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 86 multicast, 0 pause input
    281 packets output, 35537 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     56 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
R1#

This command has a lot of output. However, wading through all this information is sometimes the only way to find a problem. Table 18-4 parses and explains each important part of the show interface output.

Table 18-4 show interface Output Explanation

Output

Description

GigabitEthernet…is {up | down | administratively down}

Whether the interface hardware is currently active or down or whether an administrator has taken it down.

line protocol is {up | down}

Whether the software processes that handle the line protocol consider the interface usable (that is, whether keepalives are successful). If the interface misses three consecutive keepalives, the line protocol is marked as down.

Hardware

Hardware type (for example, MCI Ethernet, serial communications interface [SCI], cBus Ethernet) and address.

Description

Text string description configured for the interface (with a maximum of 240 characters).

Internet address

IP address followed by the prefix length (subnet mask).

MTU

Maximum transmission unit (MTU) of the interface.

BW

Bandwidth of the interface, in kilobits per second. The BW parameter is used to compute routing protocol metrics and other calculations.

DLY

Delay of the interface, in microseconds.

rely

Reliability of the interface as a fraction of 255 (where 255/255 is 100% reliability), calculated as an exponential average over 5 minutes.

load

Load on the interface as a fraction of 255 (where 255/255 is completely saturated), calculated as an exponential average over 5 minutes.

Encapsulation

Encapsulation method assigned to an interface.

Loopback

Whether the loopback is set. Can indicate a problem with the carrier.

Keepalive

Whether keepalives are set.

ARP type

Type of Address Resolution Protocol (ARP) assigned.

Last input

Number of hours, minutes, and seconds since the last packet was successfully received by an interface. Useful for knowing when a dead interface failed.

output

Number of hours, minutes, and seconds since the last packet was successfully transmitted by an interface. Useful for knowing when a dead interface failed.

output hang

Number of hours, minutes, and seconds (or never) since the interface was last reset because of a transmission that took too long. When the number of hours in any of the previous fields exceeds 24, the number of days and hours is printed. If that field overflows, asterisks are printed.

Last clearing

Time at which the counters that measure cumulative statistics shown in this report (such as number of bytes transmitted and received) were last reset to 0. Note that variables that might affect routing (for example, load and reliability) are not cleared when the counters are cleared. Asterisks indicate elapsed time too large to be displayed. Reset the counters with the clear interface command.

Output queue, input queue, drops queue

Number of packets in output and input queues. Each number is followed by a slash (/), the maximum size of the queue, and the number of packets dropped because of a full queue.

Five minute input rate, Five minute output rate

Average number of bits and packets transmitted per second in the past 5 minutes. If the interface is not in promiscuous mode, it senses network traffic that it sends and receives (instead of all network traffic). The 5-minute input and output rates should be used only as an approximation of traffic per second during a given 5-minute period. These rates are exponentially weighted averages with a time constant of 5 minutes. A period of four time constants must pass before the average will be within 2% of the instantaneous rate of a uniform stream of traffic over that period.

packets input

Total number of error-free packets the system received.

bytes input

Total number of bytes, including data and MAC encapsulation, in the error-free packets received by the system.

no buffers

Number of received packets discarded because the main system had no buffer space. Compare with ignored count. Broadcast storms on Ethernet are often responsible for no input buffer events.

Received…broadcasts

Total number of broadcast or multicast packets received by the interface. The number of broadcasts should be kept as low as practicable. An approximate threshold is less than 20% of the total number of input packets.

runts

Number of Ethernet frames that are discarded because they are smaller than the minimum Ethernet frame size. Any Ethernet frame that is less than 64 bytes is considered a runt. Runts are usually caused by collisions. If more than one runt per million bytes is received, it should be investigated.

giants

Number of Ethernet frames discarded because they exceed the maximum Ethernet frame size. Any Ethernet frame that is larger than 1518 bytes is considered a giant.

input error

Runts, giants, no buffer, cyclic redundancy check (CRC), frame, overrun, and ignored counts. Other input-related errors can also increase the input error count, and some datagrams can have more than one error. Therefore, this sum might not balance with the sum of enumerated input error counts.

CRC

CRC generated by the originating LAN station or far-end device not matching the checksum calculated from the data received. On a LAN, this usually indicates noise or transmission problems on the LAN interface or the LAN bus itself. A high number of CRCs is usually the result of collisions or a station transmitting bad data.

frame

Number of packets received as incorrectly having a CRC error and a noninteger number of octets. On a LAN, this is usually the result of collisions or a malfunctioning Ethernet device.

overrun

Number of times the receiver hardware could not hand-receive data to a hardware buffer because the input rate exceeded the capability of the receiver to handle the data.

ignored

Number of received packets ignored by the interface because the interface hardware ran low on internal buffers. These buffers are different from the system buffers mentioned in the buffer description. Broadcast storms and bursts of noise can cause the ignored count to increase.

input packets with dribble condition detected

Dribble bit error indicates that a frame is slightly too long. This frame error counter is incremented just for informational purposes; the router accepts the frame.

packets output

Total number of messages transmitted by the system.

bytes

Total number of bytes, including data and MAC encapsulation, transmitted by the system.

underruns

Number of times the transmitter has been running faster than the router can handle. This might never be reported on some interfaces.

output errors

Sum of all errors that prevented the final transmission of datagrams out the interface being examined. Note that this might not balance with the sum of the enumerated output errors because some datagrams might have more than one error and others might have errors that do not fall into any of the specifically tabulated categories.

collisions

Number of messages retransmitted because of an Ethernet collision. This is usually the result of an overextended LAN (too-long Ethernet or transceiver cable, more than two repeaters between stations, or too many cascaded multiport transceivers). A packet that collides is counted only once in output packets.

interface resets

Number of times an interface has been completely reset. This can happen if packets queued for transmission were not sent within several seconds. On a serial line, this can be caused by a malfunctioning modem that is not supplying the transmit clock signal, or it can be caused by a cable problem. If the system notices that the carrier detect line of a serial interface is up but the line protocol is down, it periodically resets the interface in an effort to restart it. Interface resets can also occur when an interface is looped back or shut down.

Basic Router Configuration with IPv6

In this section, we use the topology shown in Figure 18-2 to review the basic commands for enabling IPv6 on a router.

Figure 18-2 IPv6 Sample Topology

Command Syntax

You enable IPv6 routing by using the following command in global configuration mode:

R1(config)# ipv6 unicast-routing

Among other actions, this command configures the router to begin listening for and responding to Neighbor Discovery (ND) messages on all active IPv6 interfaces.

To configure an IPv6 address on a router’s interface, you have one of several options:

  • Configure the interface to use the EUI-64 method of addressing:

    Router(config)# ipv6 address ipv6-prefix/prefix-length eui-64
  • Configure the full global unicast address. To manually configure a full IPv6 address, use the following command syntax:

    Router(config)# ipv6 address ipv6-address/prefix-length
  • Configure the interface as unnumbered (see Day 27, “IPv6 Addressing”).

  • Configure the interface as a DHCPv6 client (see Day 23, “DHCP and DNS”).

Configuration Example

The preferred IPv6 configuration method often is to manually configure the full IPv6 address because you can control the number of hexadecimal digits you must type when testing connectivity or troubleshooting a problem. You can see this by comparing the EUI-64 method to a full configuration. In Example 18-4. the interfaces on R1 are all configured using the EUI-64 method.

Example 18-4 Configuring Interfaces Using the EUI-64 Method

R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:1::/64 eui-64
R1(config-if)# interface g0/1
R1(config-if)# ipv6 address 2001:db8:acad:2::/64 eui-64
R1(config-if)# interface s0/0/0
R1(config-if)# ipv6 address 2001:db8:acad:3::/64 eui-64
R1(config-if)# do show ipv6 interface brief
GigabitEthernet0/0 [up/up]
    FE80::2D0:97FF:FE20:A101
    2001:DB8:ACAD:1:2D0:97FF:FE20:A101
GigabitEthernet0/1   [up/up]
    FE80::2D0:97FF:FE20:A102
    2001:DB8:ACAD:2:2D0:97FF:FE20:A102
Serial0/0/0          [down/down]
   FE80::20C:CFFF:FE77:A401
   2001:DB8:ACAD:3:20C:CFFF:FE77:A401
<output omitted>

Notice the number of hexadecimal digits in the IPv6 addresses highlighted in the output from the show ipv6 interface brief command. Imagine having to ping the GigabitEthernet 0/0 address 2001:DB8:ACAD:1:2D0:97FF:FE20:A101.

Furthermore, notice that the link-local addresses are also rather complex. To reduce the complexity of the router’s configuration, verification, and troubleshooting, it is a good practice to manually configure the link-local address as well as the IPv6 global unicast address. In Example 18-5. R1 is reconfigured with simpler IPv6 addresses and with FE80::1 as the link-local address on all interfaces. Remember that the link-local address needs to be unique only on that interface’s link.

Example 18-5 Full IPv6 Address and Link-Local Address Configuration

R1(config-if)# interface g0/0
R1(config-if)# no ipv6 address 2001:db8:acad:1::/64 eui-64
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# interface g0/1
R1(config-if)# no ipv6 address 2001:db8:acad:2::/64 eui-64
R1(config-if)# ipv6 address 2001:db8:acad:2::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# interface s0/0/0
R1(config-if)# no ipv6 address 2001:db8:acad:3::/64 eui-64
R1(config-if)# ipv6 address 2001:db8:acad:3::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# do show ipv6 interface brief
GigabitEthernet0/0     [up/up]
   FE80::1
   2001:DB8:ACAD:1::1
GigabitEthernet0/1     [up/up]
   FE80::1
   2001:DB8:ACAD:2::1
Serial0/0/0           [down/down]
   FE80::1
   2001:DB8:ACAD:3::1
<output omitted>

Compare the highlighted output from the show ipv6 interface brief command in Example 18-5 with the output in Example 18-4. You can see that simplifying the IPv6 addressing implementation can make your verification and troubleshooting job much easier.

To verify the full configuration of an interface, use the show ipv6 interface command. Example 18-6 shows the output for R1’s GigabitEthernet 0/0 interface.

Example 18-6 The show ipv6 interface gigabitethernet 0/0 Command

R1# show ipv6 interface gigabitethernet 0/0
GigabitEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1
  No Virtual link-local address(es):
  Global unicast address(es):
   2001:DB8:ACAD:1::1, subnet is 2001:DB8:ACAD:1::/64
  Joined group address(es):
   FF02::1
   FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

Focus on the highlighted output in Example 18-6. IPv6 is enabled on this interface with a nice, short link-local address. The global unicast address and its subnet are listed, as is the address of multicast groups that this interface automatically joined. Do you remember what the FF02::1 and FF02::1:FF00:1 addresses are used for? If not, revisit Day 27.

That’s all the IPv6 configurations for today. As we continue to review the exam topics in the upcoming days, we will incorporate IPv6 topics.

Verifying IPv4 and IPv6 Network Connectivity

As reviewed on Day 29, “Switch Configuration Basics,” ping and traceroute are helpful tools for verifying network connectivity. Example 18-7 demonstrates successful ping output on the router.

Example 18-7 Successful ping Output on a Router

R1# ping 192.168.3.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
!Pinging an IPv6 destination
R1# ping 2001:db8:acad:1:290:dff:fee5:8095

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ACAD:1:290:CFF:FEE5:8095, timeout is 2
  seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/9/46 ms

R1#

Unsuccessful ping output shows periods (.) instead of exclamation points (!), as Example 18-8 demonstrates. The output would be the same in IPv6.

Example 18-8 Unsuccessful ping Output on a Router

R1# ping 192.168.3.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

Example 18-9 shows output from a successful traceroute command.

Example 18-9 Successful traceroute Output on a Router

R1# traceroute 192.168.3.10
Type escape sequence to abort.
Tracing the route to 192.168.3.10

  1  192.168.2.2    71 msec   70 msec  72 msec
  2  192.168.3.10  111 msec  133 msec  115 msec
R1#
!Tracing to an IPv6 destination.
R2# traceroute 2001:db8:acad:1:290:cff:fee5:8095
Type escape sequence to abort.
Tracing the route to 2001:DB8:ACAD:1:290:CFF:FEE5:8095

  1 2001:DB8:ACAD:3::1 1 msec 1 msec 1 msec
  2 2001:DB8:ACAD:1:290:CFF:FEE5:8095 1 msec 1 msec 0 msec
R2#

Unsuccessful traces show the last successful hop and the asterisks for each attempt until the user cancels. To cancel the traceroute command on a router, use the key combination Ctrl+Shift+6 and then press the x key. Example 18-10 shows unsuccessful traceroute output. The output would be the same with IPv6.

Example 18-10 Unsuccessful traceroute Output on a Router

R1# traceroute 192.168.3.2
Type escape sequence to abort.
Tracing the route to 192.168.3.2

 1 192.168.2.2 71 msec 70 msec 72 msec
 2 *    *    *
 3 *    *    *
 4 *    *    *
 5 *
R1#

Using Telnet or SSH to remotely access another device also tests connectivity. More important, these remote access methods test whether a device has been correctly configured so that you can access it for management purposes. This can be important when a device is truly remote (for example, across town or in another city). Day 20, “LAN Security and Device Hardening” reviews SSH configuration and verification in greater detail.

During the basic configuration tasks earlier, you entered the commands to properly configure the vty lines for SSH remote access. If you are accessing a device configured with SSH from a PC, you use the SSH setting in your terminal client. However, you can use the ssh command on a router or switch to access another device configured with SSH. Example 18-11 shows how to use SSH to remotely access R2 from R1.

Example 18-11 Remote Access Using SSH

R1# ssh ?
  -c Select encryption algorithm
  -l Log in using this user name
  -m Select HMAC algorithm
  -o Specify options
  -p Connect to this port
  -v Specify SSH Protocol Version
  -vrf Specify vrf name
   WORD IP address or hostname of a remote system

R1# ssh –l ?
  WORD Login name
R1# ssh -l admin ?
  -c Select encryption algorithm
  -m Select HMAC algorithm
  -o Specify options
  -p Connect to this port
  -v Specify SSH Protocol Version
  -vrf Specify vrf name
  WORD IP address or hostname of a remote system
R1# ssh -l admin 192.168.2.2
Password:

******************************************
WARNING!! Unauthorized Access Prohibited!!
******************************************

R2>

Small Office or Home Office Routers

Figure 18-3 shows the common options for small office or home office (SOHO) Internet connections.

Figure 18-3 Common SOHO Internet Connections

The connection options shown in Figure 18-3 are as follows:

  • Cable: Typically offered by cable television (CATV) service providers, cable transmits the Internet data signal on the same cable that delivers cable television. It provides high bandwidth, high availability, and an always-on connection to the Internet.

  • DSL: Digital Subscriber Line, which runs over telephone lines, provides high bandwidth, high availability, and an always-on connection to the Internet.

  • Cellular: Cellular Internet access uses a cell phone network to connect. Wherever you can get a cellular signal, you can get cellular Internet access. Performance is limited by the capabilities of the phone and the cell tower to which it is connected.

  • Satellite: Satellite Internet access is used in areas that would otherwise have no Internet connectivity at all. Satellite dishes require a clear line of sight to the satellite.

  • Dial-up telephone: Dial-up is a low-bandwidth option that uses any phone line and a modem. Dial-up is considered a legacy technology, but you might see it on the exam.

A SOHO router is typically used to create the connection to the home user and small office connections in Figure 18-4. SOHO routers typically have two features that an enterprise router would be less likely to have:

  • SOHO routers almost always use the Internet and virtual private network (VPN) technology for their WAN connections to send data back and forth to the rest of the enterprise.

  • A SOHO router is almost always a multifunction device that does routing, LAN switching, VPN, wireless, and maybe other features.

Figure 18-4 Internal Functions SOHO Router

Figure 18-4 shows a typical SOHO site. The three icons that represent a router, a switch, and an access point actually all exist inside one box. The UTP cables are shown only to indicate that these devices are connected. The actual connection is in the hardware of the SOHO router. On the left, the SOHO router provides wired and wireless LAN servers, and on the right, it provides WAN access through a cable Internet connection.

Basic IP Addressing Troubleshooting

If you are sure you manually configured the correct IP address and subnet mask (IPv4) or network prefix (IPv6), then any basic IP addressing issue is likely to be the result of a misconfigured default gateway or duplicate addresses.

Default Gateway

A misconfigured default gateway is one of the most common problems in either a static or dynamically assigned IP addressing scheme. For a device to communicate across multiple networks, it must be configured with an IP address, a subnet mask or network prefix, and a default gateway.

The default gateway is used when the host wants to send a packet to a device on another network. The default gateway address is generally the router interface address attached to the local network to which the host is connected.

To resolve a default gateway that was manually configured incorrectly, consult the topology and addressing documentation to verify what the device’s default gateway should be; it is normally a router attached to the same LAN.

Duplicate IP Addresses

Under some circumstances, duplicate IP address conflicts can occur between a statically configured network device and a PC obtaining automatic IP addressing information from the DHCP server. To resolve such an IP addressing conflict, you can do one of the following:

  • Convert the network device with the static IP address to a DHCP client

  • On the DHCP server, exclude the static IP address of the end device from the DHCP pool of addresses

The first solution is a quick fix that you can do in the field. However, the device more than likely needs a static configuration. The second solution might be the better long-term choice. However, it requires that you have administrative privileges to configure the DHCP server.

You might also encounter IP addressing conflicts when manually configuring IP on an end device in a network that uses only static IP addresses. In this case, you must determine which IP addresses are available on the particular IP subnet and configure accordingly. This case illustrates why it is so important for a network administrator to maintain detailed documentation, including IP address assignments and topologies, for end devices.

Study Resources

For today’s exam topics, refer to the following resources for more study.

Resource

Module or Chapter

Introduction to Networks v7

10

17

Switching, Routing, and Wireless Essentials

1

CCNA 200-301 Official Cert Guide, Volume 1

15

Portable Command Guide

14

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.128.29.47