Trouble Ticket Solutions

These solutions are not always the only way to perform these tasks. Compare your results.

Trouble Ticket 1 Solution

Turn on the debug bri command in Example 9-51 to watch the TEI negotiation.

Example 9-51. TEI Negotiation
r5#debug bri
Basic Rate network interface debugging is on
r5#!!!unplug the cable
Dec 23 06:51:14.784: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:51:14.792: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:51:14.792: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:51:25.404: BRI: write_sid: scp = 0, wrote = 92
Dec 23 06:51:25.404: BRI: write_sid: scp = 90, wrote = 93
Dec 23 06:51:25.408: BRI0: ACTIVATED, state F2, event DI
							Dec 23 06:51:25.408: BRI: T4 timer started DEACT timer expired
Dec 23 06:51:26.012: BRI: write_sid: scp = 0, wrote = 92
Dec 23 06:51:26.012: BRI: write_sid: scp = 90, wrote = 93
Dec 23 06:51:26.016: BRI: write_sid: scp = 0, wrote = 1
Dec 23 06:51:26.016: BRI: write_sid: scp = 0, wrote = 0
Dec 23 06:51:26.020:  isdn_Call_disconnect()
							Dec 23 06:51:26.020:  isdn_Call_disconnect()
							Dec 23 06:51:26.024: BRI: disable channel B1
							Dec 23 06:51:26.024: BRI: disable channel B2

r5#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
							DEACTIVATED
    Layer 2 Status:
        TEI = 118, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        TEI = 119, Ces = 2, SAPI = 0, State = TEI_ASSIGNED
    Spid Status:
        TEI 118, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 119, ces = 2, state = 5(init)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 4, tid = 1
...
r5#!!!plug cable back in
Dec 23 06:52:11.132: BRI: write_sid: scp = 0, wrote = 92
Dec 23 06:52:11.132: BRI: write_sid: scp = 80, wrote = 93
Dec 23 06:52:11.132: BRI0: DEACTIVATED, state F1, event LSD
Dec 23 06:52:11.136: BRI: write_sid: scp = 0, wrote = 1B
Dec 23 06:52:11.140: BRI: write_sid: scp = 0, wrote = 20
Dec 23 06:52:11.200: BRI: write_sid: scp = 0, wrote = 92
Dec 23 06:52:11.200: BRI: write_sid: scp = A0, wrote = 93
Dec 23 06:52:11.204: BRI0: DEACTIVATED, state F3, event AP
Dec 23 06:52:11.204: BRI: write_sid: scp = 0, wrote = 3
Dec 23 06:52:11.216: BRI: write_sid: scp = 0, wrote = 92
Dec 23 06:52:11.216: BRI: write_sid: scp = E0, wrote = 93
Dec 23 06:52:11.216: BRI0: PENDING, state F7, event AI
							Dec 23 06:52:11.220: BRI: Received activation indication.
Dec 23 06:52:11.232: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:11.388: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 118
							changed to down
							Dec 23 06:52:11.388: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 119
							changed to down
Dec 23 06:52:11.392: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 118 changed
  to down
Dec 23 06:52:11.420: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.420: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.532: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.556: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 70 changed
							to up
Dec 23 06:52:13.564: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.644: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.664: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.700: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.724: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 71 changed
							to up
Dec 23 06:52:13.732: BRI: write_sid: scp = 0, wrote = E
Dec 23 06:52:13.816: BRI: write_sid: scp = 0, wrote = E
r5#no debug bri
						

This is a little more output than you want occurring on a regular basis, so keep that in mind to find the best time to issue the command. The output continuously displays write sid, which is an internal command written to the interface controller subunit identifier (SID). With the cable unplugged, the activation timer (T3) expired and the status was F2. The timers deactivated, the call terminated, and both B channels went down. Also note the Layer2Down messages. In summary, if there are quick BRI interface changes, always check the Physical Layer, such as the cable or interface. Unless you want to see all the TEI negotiation in the background, however, show isdn status is still the best tool for troubleshooting ISDN layers.

Trouble Ticket 2 Solution

The obvious issue is the missing ISDN switch type or mismatch that show isdn status reveals quite nicely. When Layer 1 is deactivated, you should immediately suspect a bad cable or the switch type. You might want to take a few minutes and remove your switch type as in the following output and then fix the issues. Glance at the output of show isdn status in Example 9-52 before you make any changes. Note any complications.

Example 9-52. show isdn status Command Output
r5#show isdn status
							Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 70, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 71, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Spid Status:
        TEI 70, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 71, ces = 2, state = 5(init)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 4, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0

Now remove both the global interface switch types for r5 in Example 9-53.

Example 9-53. Removing the ISDN Switch Types
r5(config)#interface bri0
r5(config-if)#no isdn switch-type
							Warning: No ISDN switch-type defined.  No calls possible.
r5(config-if)#exit
Dec 23 07:09:52.456: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 70 changed
  to down
Dec 23 07:09:52.460: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 70 changed
  to down
Dec 23 07:09:52.628: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 71 changed
  to down
Dec 23 07:09:52.632: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 71 changed
  to down
r5(config)#no isdn switch-type
							Warning: No ISDN switch-type defined.  No calls possible, unless switchtype defined 
Globally and/or per interface.
							This change will take full effect upon reload.
r5(config)#end
r5#copy running-config startup-config
r5#reload
r5#show isdn status
							**** No Global ISDN Switchtype currently defined ****
							ISDN BRI0 interface
							dsl 0, interface ISDN Switchtype = none
							Layer 1 Status:
							DEACTIVATED
							!!!now define your switch type and test
r5#configure terminal
r5(config)#isdn switch-type basic-ni
							Dec 23 07:17:13.171: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 72 changed
							to up
							Dec 23 07:17:13.339: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 73 changed
							to up
r5(config)#end
r5#copy running-config startup-config
						

The main complication to note is that when you completely remove the ISDN switch type the router warns you that no calls are possible. It also does not take effect until you reload the router. Just like other features, however, you may run into slight differences with the version of code.

Trouble Ticket 3 Solution

First remove your SPIDs from r5 as in Example 9-54. Then clear the BRI interface and show the ISDN status.

Example 9-54. Removing SPIDs
r5#show run interface bri0
interface BRI0
 ip address 192.168.9.22 255.255.255.252
 no ip directed-broadcast
 dialer idle-timeout 55
 dialer map ip 192.168.9.21 name r6 8358661
 dialer map ip 192.168.9.21 name r6 8358663
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
							isdn spid2 0835866401 8358664
end

r5#configure terminal
r5(config)#interface bri0
r5(config-if)#no isdn spid1 0835866201 8358662
r5(config-if)#no isdn spid2 0835866401 8358664
r5(config-if)#end
r5#clear interface bri0
Dec 23 07:24:13.107:  isdn_Call_disconnect()
Dec 23 07:24:13.111:  isdn_Call_disconnect()
Dec 23 07:24:13.299: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 72 changed
  to down
Dec 23 07:24:13.303: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 73 changed
  to down
Dec 23 07:24:13.307: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 72 changed
  to down
Dec 23 07:24:14.111: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
Dec 23 07:24:14.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2,
  changed state to down
Dec 23 07:24:15.475: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 74 changed
  to up
r5#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
							TEI = 74, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0

Note how I first issued the show run interface bri0 command so that I had the commands right in front of me that I wanted to delete. I used clear interface bri0 to clear the interface so that this would take effect. TEI was not assigned as you can see by the SPID status. Now add one SPID back at a time and observe the results in Example 9-55.

Example 9-55. Configuring SPIDs (First B Channel)
							r5#!!!add one SPID back at a time
r5#configure terminal
r5(config)#interface bri0
r5(config-if)#isdn spid1 0835866201 8358662
r5(config-if)#end
r5#clear interface bri0
r5#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 75, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Spid Status:
							TEI 75, ces = 1, state = 5(init)
							spid1 configured, spid1 sent, spid1 valid
							Endpoint ID Info: epsf = 0, usid = 2, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0

Focus on the ISDN Layer 2 status. Your key is the MULTIPLE_FRAME_ESTABLISHED state for each B channel. When you removed both SPIDs and added one back, however, you only saw one MULTIPLE_FRAME_ESTABLISHED. Add the other SPID back in Example 9-56 and observe the results.

Example 9-56. Configuring SPIDs (Second B Channel)
							r5#!!!now add the other SPID
r5#configure terminal
r5(config)#interface bri0
r5(config-if)#isdn spid2 0835866401 8358664
r5(config-if)#end
r5#clear interface bri0
r5#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 76, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
							TEI = 77, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Spid Status:
        TEI 76, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 77, ces = 2, state = 5(init)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 4, tid = 1

The moral of this ticket is MULTIPLE_FRAME_ESTABLISHED and valid SPIDs. The tool is show isdn status.

Trouble Ticket 4 Solution

Configure PPP encapsulation with PAP authentication on the ISDN bri0 interfaces to produce the configurations in Example 9-57.

Example 9-57. Configuring PPP Encapsulation and PAP Authentication
r5#show running-config
hostname r5
enable password cisco
username r6 password 0 donna
ip subnet-zero
isdn switch-type basic-ni
...
interface Loopback8
 ip address 5.5.5.5 255.255.255.255
 no ip directed-broadcast
!
interface Serial0
 bandwidth 64
 ip address 192.168.9.14 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
!
interface Serial1
 bandwidth 64
 ip address 192.168.9.18 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 192.168.9.22 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 55
 dialer map ip 192.168.9.21 name r6 8358661
 dialer map ip 192.168.9.21 name r6 8358663
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication pap callin
							ppp pap sent-username paplady password 7 0117090A550A
...
end

r6#show running-config
hostname r6
!
username r5 password 0 donna
username paplady password 0 donna
ip subnet-zero
isdn switch-type basic-ni
!
interface Loopback9
 ip address 6.6.6.6 255.255.255.255
 no ip directed-broadcast
!
interface Serial0
 bandwidth 64
 ip address 192.168.9.17 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
 clockrate 64000
 ppp authentication chap
!
...
interface BRI0
 ip address 192.168.9.21 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 55
 dialer map ip 192.168.9.22 name r5 8358662
 dialer map ip 192.168.9.22 name r5 8358664
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 ppp authentication pap
...
end

Turn on the debug ppp negotiation command to watch the authentication process in Example 9-58.

Example 9-58. Debug PPP Negotiation over ISDN
r5#debug ppp negotiation
PPP protocol negotiation debugging is on
r5#ping 192.168.9.21
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.21, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/37/40 ms
Dec 23 08:11:17.355: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
Dec 23 08:11:17.391: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358661
Dec 23 08:11:17.399: BR0:1 PPP: Treating connection as a callout
							Dec 23 08:11:17.399: BR0:1 PPP: Phase is ESTABLISHING, Active Open
							Dec 23 08:11:17.403: BR0:1 PPP: No remote authentication for call-out
							Dec 23 08:11:17.403: BR0:1 LCP: O CONFREQ [Closed] id 3 len 10
							Dec 23 08:11:17.407: BR0:1 LCP:    MagicNumber 0x0042EEFD (0x05060042EEFD)
Dec 23 08:11:17.423: BR0:1 LCP: I CONFREQ [REQsent] id 3 len 14
Dec 23 08:11:17.427: BR0:1 LCP:    AuthProto PAP (0x0304C023)
Dec 23 08:11:17.431: BR0:1 LCP:    MagicNumber 0x172FC497 (0x0506172FC497)
Dec 23 08:11:17.431: BR0:1 LCP: O CONFACK [REQsent] id 3 len 14
							Dec 23 08:11:17.435: BR0:1 LCP:    AuthProto PAP (0x0304C023)
							Dec 23 08:11:17.439: BR0:1 LCP:    MagicNumber 0x172FC497 (0x0506172FC497)
Dec 23 08:11:17.443: BR0:1 LCP: I CONFACK [ACKsent] id 3 len 10
Dec 23 08:11:17.443: BR0:1 LCP:    MagicNumber 0x0042EEFD (0x05060042EEFD)
Dec 23 08:11:17.447: BR0:1 LCP: State is Open
							Dec 23 08:11:17.451: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
							Dec 23 08:11:17.459: BR0:1 PAP: O AUTH-REQ id 3 len 18 from "paplady"
Dec 23 08:11:17.475: BR0:1 PAP: I AUTH-ACK id 3 len 5
Dec 23 08:11:17.479: BR0:1 PPP: Phase is UP
							Dec 23 08:11:17.483: BR0:1 IPCP: O CONFREQ [Closed] id 3 len 10
							Dec 23 08:11:17.487: BR0:1 IPCP:    Address 192.168.9.22 (0x0306C0A80916)
							Dec 23 08:11:17.491: BR0:1 CDPCP: O CONFREQ [Closed] id 3 len 4
Dec 23 08:11:17.495: BR0:1 IPCP: I CONFREQ [REQsent] id 3 len 10
Dec 23 08:11:17.495: BR0:1 IPCP:    Address 192.168.9.21 (0x0306C0A80915)
Dec 23 08:11:17.499: BR0:1 IPCP: O CONFACK [REQsent] id 3 len 10
							Dec 23 08:11:17.503: BR0:1 IPCP:    Address 192.168.9.21 (0x0306C0A80915)
Dec 23 08:11:17.507: BR0:1 CDPCP: I CONFREQ [REQsent] id 3 len 4
Dec 23 08:11:17.511: BR0:1 CDPCP: O CONFACK [REQsent] id 3 len 4
Dec 23 08:11:17.515: BR0:1 IPCP: I CONFACK [ACKsent] id 3 len 10
Dec 23 08:11:17.519: BR0:1 IPCP:    Address 192.168.9.22 (0x0306C0A80916)
Dec 23 08:11:17.519: BR0:1 IPCP: State is Open
Dec 23 08:11:17.523: BR0:1 CDPCP: I CONFACK [ACKsent] id 3 len 4
Dec 23 08:11:17.527: BR0:1 CDPCP: State is Open
Dec 23 08:11:17.535: BR0 IPCP: Install route to 192.168.9.21
Dec 23 08:11:18.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
							changed state to up
Dec 23 08:11:23.395: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358661 r6
!!!now for the disconnect
Dec 23 08:12:14.115: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 8358661 r6,
 call lasted 56 seconds
Dec 23 08:12:14.227:  isdn_Call_disconnect()
Dec 23 08:12:14.227: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
Dec 23 08:12:14.259: BR0:1 IPCP: State is Closed
Dec 23 08:12:14.263: BR0:1 CDPCP: State is Closed
Dec 23 08:12:14.263: BR0:1 PPP: Phase is TERMINATING
Dec 23 08:12:14.267: BR0:1 LCP: State is Closed
Dec 23 08:12:14.267: BR0:1 PPP: Phase is DOWN
Dec 23 08:12:14.271: BR0 IPCP: Remove route to 192.168.9.21
Dec 23 08:12:15.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
r5#u all
						

PAP is a one-way challenge performed one time. Notice the authentication request and acknowledgment. The commands debug ppp authentication and debug ppp negotiation are quite helpful in troubleshooting authentication issues. In my test, r5 was the calling router and r6 was the called router. Reference the CCO “Configuring and Troubleshooting PAP” Tech Note at Cisco.com for more detail.

Trouble Ticket 5 Solution

Refer back to the initial chapter scenario in Figure 9-1 for the physical layout of your lab. Use Figure 9-9 as a more detailed view of r5 and r6. Configure IS-IS on r5 and r6 as in Example 9-59. If you want to see more of what is going on you can log the adjacency changes for IS-IS.

Example 9-59. Configuring IS-IS on r5 and r6
r5#configure terminal
r5(config)#router isis
r5(config-router)#net ?
  XX.XXXX. ... .XXX.XX  Network entity title (NET)
r5(config-router)#net 49.0001.5555.5555.00
r5(config-router)#interface s1
r5(config-if)#ip router isis
Dec 23 08:20:26.927: Se1 PPP: Outbound clns_es packet dropped, OSICP is Closed
  [starting negotiations]
Dec 23 08:20:26.927: Se1 OSICP: State is Listen
Dec 23 08:20:26.931: Se1 OSICP: TIMEout: State Listen
Dec 23 08:20:26.935: Se1 OSICP: O CONFREQ [Listen] id 1 len 4
Dec 23 08:20:26.947: Se1 LCP: I PROTREJ [Open] id 47 len 10 protocol OSICP
  (0x802301010004)
Dec 23 08:20:26.947: Se1 OSICP: State is Closed
Dec 23 08:20:27.083: Se1 PPP: Outbound clns_is packet dropped, OSICP is Closed
  [starting negotiations]
Dec 23 08:20:27.087: Se1 OSICP: State is Closed
Dec 23 08:20:27.091: Se1 OSICP: TIMEout: State Closed
Dec 23 08:20:27.091: Se1 OSICP: State is Listen
r5(config-if)#interface loopback 8
r5(config-if)#ip router isis
r5(config-if)#router eigrp 109
							!!!no need to send any eigrp advertisements on s1 or lo8
r5(config-router)#passive-interface s1
r5(config-router)#passive-interface lo8
r5(config-router)#end
r5#copy running-config startup-config

r6#configure terminal
r6(config)#no router eigrp 109
r6(config)#router isis
r6(config-router)#net 49.0001.6666.6666.00
r6(config-router)#interface s0
r6(config-if)#ip router isis
r6(config-if)#interface loopback 9
r6(config-if)#ip router isis
r6(config-if)#end
r6#copy running-config startup-config
						

Now that IS-IS is configured, view your neighbors, the topology, the database, and your interfaces in Example 9-60.

Example 9-60. Verifying IS-IS
r6#show clns neighbors
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0001.5555.5555 Se0         *PPP*               Up     28        L1L2 IS-IS

r6#show isis ?
  database     IS-IS link state database
  mesh-groups  IS-IS mesh groups
  route        IS-IS level-1 routing table
  spf-log      IS-IS SPF log
  topology     IS-IS paths to Intermediate Systems

r6#show isis topology
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0001.5555.5555  10      0001.5555.5555  Se0             *PPP*
0001.6666.6666  --

IS-IS paths to level-2 routers
System Id       Metric  Next-Hop        Interface       SNPA
0001.5555.5555  10      0001.5555.5555  Se0             *PPP*
0001.6666.6666  --

r6#show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
0001.5555.5555.00-00  0x00000004   0x58C6        1043              0/0/0
0001.5555.5555.01-00  0x00000001   0x3DF8        934               0/0/0
0001.6666.6666.00-00* 0x00000004   0x8FFE        1053              0/0/0
0001.6666.6666.01-00* 0x00000001   0x0AA3        1057              0/0/0

IS-IS Level-2 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
0001.5555.5555.00-00  0x00000005   0x68C5        1053              0/0/0
0001.6666.6666.00-00* 0x00000005   0x18CC        1058              0/0/0
r6#

r6#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   192.168.9.21    YES manual up                    up
BRI0:1                 unassigned      YES unset  down                  down
BRI0:2                 unassigned      YES unset  down                  down
Ethernet0              unassigned      YES unset  administratively down down
Loopback9              6.6.6.6         YES NVRAM  up                    up
Serial0                192.168.9.17    YES NVRAM  up                    up
Serial1                unassigned      YES unset  administratively down down
Serial2                unassigned      YES unset  administratively down down
Serial3                unassigned      YES unset  administratively down down

r6#show clns interface s0
Serial0 is up, line protocol is up
  Checksums enabled, MTU 1500, Encapsulation PPP
  ERPDUs enabled, min. interval 10 msec.
  RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
  Congestion Experienced bit set at 4 packets
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 49 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x100
    Level-1 Metric: 10, Priority: 64, Circuit ID: 0001.6666.6666.00
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: 0001.6666.6666.00
    Number of active level-2 adjacencies: 1
    Next IS-IS Hello in 5 seconds

If for some reason you do not have neighbors or adjacencies, don't assume it is an IS-IS issue. You have made lots of encapsulation changes in this chapter, and I would expect that to be a major target here. The debug isis adj-packets command in Example 9-61 can help you determine such issues.

Example 9-61. debug isis adj-packets
r5#debug isis adj-packets
IS-IS Adjacency related packets debugging is on
r5#
Jul 20 07:10:34: ISIS-Adj: Sending L2 IIH on Loopback8
Jul 20 07:10:34: ISIS-Adj: Sending L1 IIH on Loopback8
Jul 20 07:10:36: ISIS-Adj: Sending L1 IIH on Loopback8
Jul 20 07:10:37: ISIS-Adj: Sending L2 IIH on Loopback8
Jul 20 07:10:38: ISIS-Adj: Encapsulation failed on serial IIH (Serial1)
...
r5#undebug all
						

Change the encapsulation of r5s1 and r6s0 to HDLC as in Example 9-62. If you did not experience the “encapsulation failed” message in Example 9-61, you certainly can force that to happen here between your configuration of r5 and r6. Display the routing tables on both r5 and r6 to verify reachability information to all subnets in Example 9-63.

Example 9-62. HDLC Encapsulation
r5(config)#interface s1
r5(config-if)#shut
r5(config-if)#encap hdlc
r5(config-if)#no shut

r6(config)#interface s0
r6(config-if)#shut
r6(config-if)#encap hdlc
r6(config-if)#no shut
						

Example 9-63. Routing Tables
r5#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/41152000] via 192.168.9.13, 00:01:33, Serial0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/41152000] via 192.168.9.13, 00:01:33, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/40640000] via 192.168.9.13, 00:01:33, Serial0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/41152000] via 192.168.9.13, 00:01:33, Serial0
     192.168.9.0/24 is variably subnetted, 10 subnets, 2 masks
D       192.168.9.1/32 [90/41024000] via 192.168.9.13, 00:01:33, Serial0
D       192.168.9.0/30 [90/41024000] via 192.168.9.13, 00:01:33, Serial0
D       192.168.9.4/30 [90/41024000] via 192.168.9.13, 00:01:34, Serial0
D       192.168.9.6/32 [90/41024000] via 192.168.9.13, 00:01:34, Serial0
D       192.168.9.8/30 [90/41024000] via 192.168.9.13, 00:01:34, Serial0
D       192.168.9.10/32 [90/41024000] via 192.168.9.13, 00:01:35, Serial0
C       192.168.9.13/32 is directly connected, Serial0
C       192.168.9.12/30 is directly connected, Serial0
C       192.168.9.16/30 is directly connected, Serial1
C       192.168.9.20/30 is directly connected, BRI0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback8
     6.0.0.0/32 is subnetted, 1 subnets
i L1    6.6.6.6 [115/20] via 192.168.9.17, Serial1

r6#show ip route
     192.168.9.0/30 is subnetted, 2 subnets
C       192.168.9.16 is directly connected, Serial0
C       192.168.9.20 is directly connected, BRI0
     5.0.0.0/32 is subnetted, 1 subnets
i L1    5.5.5.5 [115/20] via 192.168.9.18, Serial0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback9

Instead of redistributing between IS-IS and EIGRP on r5, have r5 advertise a default route via IS-IS as in Example 9-64. Verify connectivity via the loopbacks.

Example 9-64. Advertising a Default Route
r5#configure terminal
r5(config)#router isis
r5(config-router)#default-information originate
r5(config-router)#end
r6#show ip route
							Gateway of last resort is 192.168.9.18 to network 0.0.0.0
     192.168.9.0/30 is subnetted, 2 subnets
C       192.168.9.16 is directly connected, Serial0
C       192.168.9.20 is directly connected, BRI0
     5.0.0.0/32 is subnetted, 1 subnets
i L1    5.5.5.5 [115/20] via 192.168.9.18, Serial0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback9
i*L2 0.0.0.0/0 [115/10] via 192.168.9.18, Serial0

r6#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/88/92 ms
= 4/4/4 ms
r6#copy running-config startup-config
r5#copy running-config startup-config
						

In your earlier testing, you should have noticed that r6 did not have a route to get to the remote networks. With the default-information originate command, IS-IS sent a default route to the others regardless of whether a default route existed in the routing table.

Remove the IS-IS default-information originate and any other static/default routes in r5 and r6. Configure one-way redistribution from EIGRP into IS-IS on r5 as in Example 9-65.

Example 9-65. Redistributing EIGRP into IS-IS
r5(config-router)#redistribute eigrp 109 metric ?
  <0-63>  ISIS default metric
r5(config-router)#redistribute eigrp 109 metric 50
r5(config-router)#end

r5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/41152000] via 192.168.9.13, 00:07:53, Serial0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/41152000] via 192.168.9.13, 00:07:54, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/40640000] via 192.168.9.13, 00:07:54, Serial0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/41152000] via 192.168.9.13, 00:07:54, Serial0
     192.168.9.0/24 is variably subnetted, 9 subnets, 2 masks
D       192.168.9.1/32 [90/41024000] via 192.168.9.13, 00:07:54, Serial0
D       192.168.9.0/30 [90/41024000] via 192.168.9.13, 00:07:54, Serial0
D       192.168.9.4/30 [90/41024000] via 192.168.9.13, 00:07:54, Serial0
D       192.168.9.6/32 [90/41024000] via 192.168.9.13, 00:07:54, Serial0
D       192.168.9.8/30 [90/41024000] via 192.168.9.13, 00:07:54, Serial0
D       192.168.9.10/32 [90/41024000] via 192.168.9.13, 00:07:55, Serial0
C       192.168.9.12/30 is directly connected, Serial0
C       192.168.9.16/30 is directly connected, Serial1
C       192.168.9.20/30 is directly connected, BRI0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback8
     6.0.0.0/32 is subnetted, 1 subnets
i L1    6.6.6.6 [115/20] via 192.168.9.17, Serial1

r6#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
i L2    1.1.1.1 [115/60] via 192.168.9.18, Serial0
     2.0.0.0/32 is subnetted, 1 subnets
i L2    2.2.2.2 [115/60] via 192.168.9.18, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
i L2    3.3.3.3 [115/60] via 192.168.9.18, Serial0
     4.0.0.0/32 is subnetted, 1 subnets
i L2    4.4.4.4 [115/60] via 192.168.9.18, Serial0
     192.168.9.0/24 is variably subnetted, 9 subnets, 2 masks
i L2    192.168.9.1/32 [115/60] via 192.168.9.18, Serial0
i L2    192.168.9.0/30 [115/60] via 192.168.9.18, Serial0
i L2    192.168.9.4/30 [115/60] via 192.168.9.18, Serial0
i L2    192.168.9.6/32 [115/60] via 192.168.9.18, Serial0
i L2    192.168.9.8/30 [115/60] via 192.168.9.18, Serial0
i L2    192.168.9.10/32 [115/60] via 192.168.9.18, Serial0
S       192.168.9.12/30 [1/0] via 192.168.9.22
C       192.168.9.16/30 is directly connected, Serial0
C       192.168.9.20/30 is directly connected, BRI0
     5.0.0.0/32 is subnetted, 1 subnets
i L1    5.5.5.5 [115/20] via 192.168.9.18, Serial0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback9

The issues with this Trouble Ticket were not so much IS-IS issues but mismatched encapsulation issues and lower-level WAN interface targets. However, the debug isis adj-packets command quickly identified encapsulation issues. Like OSPF, in IS-IS if you don't have neighbors that in turn means no routes either. Hence looking for neighbors is a good place to start your IS-IS troubleshooting. Use the following commands to assist with shooting other IS-IS troubles:

  • show ip protocols

  • show protocols

  • show ip route

  • clear isis *

  • log-adjacency-changes

  • show clns neighbors [detail] to verify the status of adjacencies

  • show clns interface to verify the configuration of the interface

  • show isis database to list the packets in the link-state database

  • show isis topology to list the system IDs of known IS-IS routers

  • show isis spf-log to display shortest path first events

  • debug isis adj-packets

  • debug isis update-packets

  • debug isis spf-events

Common IS-IS issues include misconfiguration, mismatched Level 1/Level 2 interfaces, area misconfiguration, and duplicate system IDs. Always check your neighbors and your logs. If you have turned on log-adjacency-changes remember to do a show logging to see the results. You may need to increase your logging buffer as well.

Now that IS-IS is working and you have full connectivity via the serial link between r5 and r6, modify the ISDN configuration to use CHAP authentication as in Example 9-66.

Example 9-66. Configuring CHAP Authentication
r5(config)#interface bri0
r5(config-if)#encap ppp
r5(config-if)#ppp authentication chap
r5(config-if)#username r6 pass donna
r5(config)#end

r6(config)#interface bri0
r6(config-if)#encap ppp
r6(config-if)#ppp authentication chap
r6(config-if)#username r5 pass donna
r6(config)#end
r5#copy running-config startup-config
r6#copy running-config startup-config
						

Ping to verify that your new configuration is operational. Shut down or remove the serial cable between r5 and r6 to make sure that the ISDN connection is used. Alternatively, configure the ISDN connection as an automatic backup to the serial link. If you want to look at the CHAP challenge again, issue the debug ppp authentication command.

Trouble Ticket 6 Solution

Thus far you have worked with the ISDN D channel for call setup and signaling and the one B channel for data traffic. Example 9-67 illustrates how to automatically bring up the second B channel if the load on the first one is more than 10 percent. To see the effect, repeat the exercise with the load at five percent if you experience problems.

Example 9-67. Configuring the dialer load-threshold
r5#clear dialer
r5#clear counters
r5#configure terminal
r5(config)#interface bri0
r5(config-if)#dialer load-threshold 25 either
r5(config-if)#end
r5#copy running-config startup-config

r6#clear dialer
r6#clear counters
r6(config)#interface bri0
r6(config-if)#dialer load-threshold 25 either
r6(config-if)#end
r6#copy running-config startup-config
						

Now that things are configured, test it as in Example 9-68.

Example 9-68. Bringing Up the Second B Channel
r5#ping
Protocol [ip]:
Target IP address: 6.6.6.6
Repeat count [5]: 100
Datagram size [100]: 1500
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: verbose
Loose, Strict, Record, Timestamp, Verbose[V]:
Sweep range of sizes [n]: y
Sweep min size [36]:
Sweep max size [18024]:
Sweep interval [1]:
Type escape sequence to abort.
Sending 1798900, [36..18024]-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Request 0 timed out (size 36)
Reply to request 1 (20 ms) (size 37)
...
Reply to request 26 (28 ms) (size 62)
Dec 24 05:49:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
							changed state to up
Reply to request 27 (32 ms) (size 63)
...
Reply to request 127 (52 ms) (size 163)
Reply to request 128 (52 ms) (size 164)
Dec 24 05:49:51: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
							8358661 r6
...
Reply to request 425 (124 ms) (size 461)
Dec 24 05:50:19: BR0 DDR: rotary group to 8358661 overloaded (27)
							Dec 24 05:50:19: BR0 DDR: Attempting to dial 8358661
							Dec 24 05:50:20: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
							Dec 24 05:50:20: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
							8358661 r6
...
Dec 24 05:50:20: BR0:2 DDR: dialer protocol up
							Dec 24 05:50:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2,
							changed state to up
Reply to request 434 (128 ms) (size 470)
...
Reply to request 440 (128 ms) (size 476)
Dec 24 05:50:21: BR0 DDR: rotary group to 8358661 underloaded (14),
							starting load activity timer
...
Dec 24 05:50:26: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to
    8358661 r6
...

As you can see in Example 9-68, extended ping is a powerful traffic generator for getting the threshold to a level to bring up the second B channel. A ping sweep of 36 to 1500 bytes is a good initial test when installing or troubleshooting devices. Over 1500 bytes doesn't buy you a whole lot, because the MTU size is 1500, but small sizes are good for latency issues. Sending 1500 bytes with a data pattern of all 1s or all 0s is a good practical test, too. The Windows default is 32 bytes, but you can use the ping -l parameter to adjust this on the PC. On the other hand, the very large ping size buys me a lot in this ticket. The packets are over 1500 bytes, so they must be fragmented, and I want to hurry up and get a load on the line to bring up the needed second B channel.

I stopped the output instead of waiting for it to finish. Verify that the second B channel was truly brought up as in Example 9-69.

Example 9-69. Verifying the Second B Channel
r5#show dialer
Dial on demand events debugging is on
BRI0 - dialer type = ISDN
Dial String      Successes   Failures    Last called   Last status
8358663                  0          0    never                   -
8358661                  2          0    00:00:44       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (55 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
							Dial reason: ip (s=192.168.9.22, d=6.6.6.6)
Time until disconnect 10 secs
Connected to 8358661 (r6)

BRI0:2 - dialer type = ISDN
Idle timer (55 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on overload
							Time until disconnect 51 secs
							Connected to 8358661 (r6)

r5#show interface bri0 1 2
							BRI0:1 is up, line protocol is up
  Hardware is BRI
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  Time to interface disconnect:  idle 00:00:02
  LCP Open
  Open: IPCP, CDPCP
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 00:02:19
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     447 packets input, 105642 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     447 packets output, 105642 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
BRI0:2 is up, line protocol is up
							Hardware is BRI
							MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 27/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  Time to interface disconnect:  idle 00:00:41
  LCP Open
  Open: IPCP, CDPCP
  Last input 00:00:05, output 00:00:05, output hang never
Dec 24 05:51:15: BR0:1 DDR: idle timeout
Dec 24 05:51:15: BR0:1 DDR: disconnecting call
Dec 24 05:51:15: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 8358661 r6
Dec 24 05:51:15: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 8358661 r6, call
 lasted 89 seconds
r5#copy running-config startup-config
						

Both B channels were in fact up but are disconnecting due to the idle timeout.

Because the load went up to about 27, the second B channel came up. 255/255 is 100-percent load. For anything less than 255, you can divide the numerator by the denominator to get the load as a percentage. You set the dialer threshold to 25, which is about .10 times 255 or 25/255.

Compare your final saved fixed configurations to the chapter 9 ending configs file. Update your documentation and fix anything that is broken. You have completed the chapter Trouble Tickets when you feel comfortable with the tasks assigned and the various scenarios throughout the chapter. Review or experiment in the areas where you need more help. Understanding and troubleshooting in a lab is certainly the basis for configuring devices in the real world. Check your understanding with the chapter review questions.

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.141.21.115