Configuring a Terminal Server (2511)

Although a terminal server (2511) is an optional piece of equipment for the lab, it provides convenience and alleviates the frustration of swapping console cables. Yes, it is true that you can telnet from device to device. However, telnet requires IP, and you are constantly making changes in the scenarios to where you do not just automatically always have in-band (IP-based) management. The terminal server provides out-of-band management, which is totally separate from your IP configuration. Figure C-2 illustrates a 2511 (an example of a terminal server) and the octal cable connections from the asynchronous interface to the router/switch console ports.

Figure C-2. Terminal Server (2511)


A terminal server works via a reverse telnet operation. Physically make your connections as in Figure C-1 to get started. Next, connect the asynchronous octal cable(s) to the 2511's 68-pin SCSI interface(s). Then connect a rolled console cable from the COM1 port (serial) on your PC to the console port on the terminal server. Power the device on and use a terminal emulator such as HyperTerm to connect. Set up your terminal settings as follows:

  • 9600 bps

  • 8 data bits

  • 0 parity bits

  • 1 stop bit

  • No flow control

Now you are ready to program the 2511 just as if it were any other router. Assign a hostname and passwords. Create a loopback address, set up a hosts table, and allow telnet, at a minimum, as the transport across the asynchronous lines 1 through 16. Example C-1 illustrates this configuration for Chapter 3, “Shooting Trouble with IP,” where you first use the terminal server.

Example C-1. Terminal Server Configuration
Router>enable
Router#configure terminal
Router(config)#hostname ts
ts(config)#enable password donna
ts(config)#line vty 0 4
ts(config-line)#login
ts(config-line)#password donna
ts(config-line)#logging synchronous
ts(config-line)#exec-timeout 30
ts(config-line)#exit
ts(config)#interface loopback 0
ts(config-if)#ip address 1.1.1.1 255.0.0.0
ts(config-if)#no shut
ts(config-if)#exit
ts(config)#ip host ?
  WORD  Name of host
ts(config)#ip host r1 ?
  <0-65535>  Default telnet port number
  A.B.C.D    Host IP address (maximum of 8)
ts(config)#ip host r1 1.1.1.1 ?
  A.B.C.D  Host IP address (maximum of 8)
  <cr>
ts(config)#ip host r1 ?
  <0-65535>  Default telnet port number
  A.B.C.D    Host IP address (maximum of 8)
ts(config)#ip host r1 2001 1.1.1.1
						ts(config)#ip host r2 2002 1.1.1.1
						ts(config)#ip host r3 2003 1.1.1.1
						ts(config)#ip host r4 2004 1.1.1.1
						ts(config)#ip host r5 2005 1.1.1.1
ts(config)#line 1 16
ts(config-line)#transport input ?
  all     All protocols
  lat     DEC LAT protocol
  mop     DEC MOP Remote Console Protocol
  nasi    NASI protocol
  none    No protocols
  pad     X.3 PAD
  rlogin  Unix rlogin protocol
  telnet  TCP/IP Telnet protocol
  v120    Async over ISDN
ts(config-line)#transport input all
						ts(config-line)#no exec
					

Save and display the terminal server (ts) final configuration. The pertinent parts are in Example C-2.

Example C-2. Terminal Server running-config
ts#copy running-config startup-config
ts#show running-config
hostname ts
enable password donna
ip host r1 2001 1.1.1.1
ip host r2 2002 1.1.1.1
ip host r3 2003 1.1.1.1
ip host r4 2004 1.1.1.1
ip host r5 2005 1.1.1.1
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
line con 0
 transport input none
line 1 16
 transport input all
 no exec
line aux 0
line vty 0 4
 password donna
 exec-timeout 30 0
 password donna
 logging synchronous
 login
end

Now that the terminal server is configured, verify its operation. The terminal server essentially connects to its own loopback address via telnet by initiating the connection out an asynchronous line. Refer back to Figure C-2 for an illustration of the asynchronous line numbers starting with 2001 and incrementing by 1. Use the hosts table to connect to all devices as in Example C-3. Without a hosts table on the terminal server, you need to issue the following commands to connect to the five devices shown:

						!!!to connect to r1
ts#telnet 1.1.1.1 2001
						!!!to connect to r2
ts#telnet 1.1.1.1 2002
						!!!to connect to r3
ts#telnet 1.1.1.1 2003
						!!!to connect to r4
ts#telnet 1.1.1.1 2004
						!!!to connect to r5
ts#telnet 1.1.1.1 2005
					

Example C-3. Opening the Terminal Server Connections
ts#show sessions
						% No connections open
ts#show hosts
Default domain is not set
Name/address lookup uses domain service
Name servers are 255.255.255.255
Host                     Flags      Age Type   Address(es)
r1                       (perm, OK)  4   IP    1.1.1.1
						r2                       (perm, OK)  4   IP    1.1.1.1
						r3                       (perm, OK)  4   IP    1.1.1.1
						r4                       (perm, OK)  4   IP    1.1.1.1
						r5                       (perm, OK)  4   IP    1.1.1.1

ts#r1
Trying r1 (1.1.1.1, 2001)... Open
r1>
r1>!!!I am pressing Ctrl+Shift+6,x to return to the ts console

ts#r2
Trying r2 (1.1.1.1, 2002)... Open
r2>
r2>!!!I am pressing Ctrl+Shift+6,x to return to the ts console

ts#r3
Trying r3 (1.1.1.1, 2003)... Open
r3>
r3>!!!I am pressing Ctrl+Shift+6,x to return to the ts console

ts#r4
Trying r4 (1.1.1.1, 2004)... Open
r4>
r4>!!!I am pressing Ctrl+Shift+6,x to return to the ts console

ts#r5
Trying r5 (1.1.1.1, 2005)... Open
r5>
r5>!!!I am pressing Ctrl+Shift+6,x to return to the ts console
ts#

Notice that I typed the hostname of each device to open a connection to it. Although not a necessity, this renders the troubleshooting easier because I aligned r1 with async line 1 (2001), r2 with async line 2 (2002), and so on. The command sequence to leave the connection open, but return to the terminal server is Ctrl+Shift+6,x. If you want to disconnect, you can issue disconnect session#. View the open sessions in Example C-4.

Example C-4. Viewing the Open Terminal Server Connections
ts#show sessions
Conn Host                Address             Byte  Idle Conn Name
   1 r1                  1.1.1.1                0     8 r1
   2 r2                  1.1.1.1                0     8 r2
   3 r3                  1.1.1.1               48     8 r3
   4 r4                  1.1.1.1               51     8 r4
*  5 r5                  1.1.1.1                0     7 r5
					

Example C-4 shows that r1 through r5 are currently open sessions and that r5 is the default because the asterisk (*) displays to the left of it. The default session is the one you end up in if you press the Enter key as I do in the following output.

ts#
[Resuming connection 5 to r5 ... ]
r5>

This time, type r5 from the terminal server rather than just the number 5 as in Example C-5.

Example C-5. Connection Refused by Remote Host
ts#r5
Trying r5 (1.1.1.1, 2005)...
% Connection refused by remote host

ts#show line
 Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*  0 CTY              -    -      -    -    -      5       0     0/0       -
*  1 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
						*  2 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
						*  3 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
						*  4 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
						*  5 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
   6 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
   7 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
*  8 TTY   9600/9600  -    -      -    -    -      0      11   424/1283    -
*  9 TTY   9600/9600  -    -      -    -    -      0      20   413/1239    -
  10 TTY   9600/9600  -    -      -    -    -      0      52   332/997     -

Line 5 is already open, but you really only needed to type 5 to get to it in the first place. However, it looks like something was already using line 8 and line 9 in the previous example. Clear these lines as in Example C-6 so that they are available for use.

Example C-6. Connection Refused by Remote Host
ts#clear line 8
[confirm]
 [OK]
ts#clear line 9
[confirm]
 [OK]
ts#show line
 Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*  0 CTY              -    -      -    -    -      5       0     0/0       -
*  1 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
*  2 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
*  3 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
*  4 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
*  5 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
   6 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
   7 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
   8 TTY   9600/9600  -    -      -    -    -      0      59   433/1312    -
   9 TTY   9600/9600  -    -      -    -    -      0     115   423/1270    -


  10 TTY   9600/9600  -    -      -    -    -      0      52   332/997     -
  11 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  12 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  13 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  14 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  15 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  16 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
  17 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -
  18 VTY              -    -      -    -    -      0       0     0/0       -
  19 VTY              -    -      -    -    -      0       0     0/0       -
  20 VTY              -    -      -    -    -      0       0     0/0       -
  21 VTY              -    -      -    -    -      0       0     0/0       -
 Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
  22 VTY              -    -      -    -    -      0       0     0/0       -

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
3.147.103.234