Scenario: Shooting Trouble with Ethernet

This chapter starts with the IPX hands-on scenario you left off with at the end of the Trouble Tickets in Chapter 4, “Shooting Trouble with Novell IPX.” The goals of the Shooting Trouble with Ethernet scenario are for you to modify your routers according to Figure 5-1 and verify end-to-end connectivity. Hostb requires use of an IPX application on the gwise server, but it should also be able to communicate via IP to the other hosts. The rest of the scenario suggests IP as the routed protocol and Enhanced Interior Gateway Routing Protocol (EIGRP) as the routing protocol using autonomous system (AS) 500. The IP subnets are the circled numbers on the wires. There should be end-to-end IP connectivity between hosta and hostc. Run IPX RIP on network number 516. The rest of the chapter deploys this scenario, so be sure to save your configurations before, during, and after you configure your devices.

Figure 5-1. Shooting Trouble with Ethernet


NOTE

My lab uses the 2514, 2501, 3640, 3620, and 2516 Cisco routers, but yours can include any number of devices that have similar interfaces. Connect the hosts off of r1e0 by way of a hub. See Appendix C, “Equipment Reference,” for the hardware used throughout this book.


Document your steps and any problems along the way. Save your work and don't forget to test things out. Remember, however, that there is not always one right or wrong way to accomplish the task or tasks presented. The ability to obtain the end result using good practices is extremely important in any real-world network. My ending configurations are printed starting in Example 5-1 through Example 5-5 so that you can compare your work. Use the previous troubleshooting checklists, your step-by-step troubleshooting methodology, and the Ethernet checklist in Table 5-1 to assist in testing. Refresh your memory by looking back at Table 3-1 (IP Checklist) and Table 4-1 (IPX Checklist) now.

NOTE

A very quick way to eliminate all IPX commands on r2 through r5 is by using the global command no ipx routing.


Table 5-1. Ethernet Layer 1 and 2 Quick Troubleshooting Checklist
Isolating ProblemsCommands and Symptoms
Cable, NIC, hub, switch

Physical inspection

Protocol analyzer

TDR/OTDR

NIC software configuration

Segmentation

Concentrate on interfaces and controllers for lower-level targets
See IP and IPX Checklists for ping, trace, and other relevant router/desktop tools.

show ip interface brief

show ipx interface brief

show controllers

show interfaces [interface]

show ip interface [interface]

show ipx interface [interface]
Driverswww.winfiles.com www.driverguide.com
Encapsulation Know your frame typesshow interfaces [interface]

show ipx interface brief

NIC diagnostics/properties
Autonegotiation

Speed issues cause connectivity problems

Duplex issues cause performance problems
show interface [interface] Collisions on a full-duplex link, for example.
One-way link You can receive but can't transmit or vice versaCheck the cable.

Example 5-1. r1 Configuration (2514)
r1#show running-config
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r1
enable secret 5 $1$m0s2$Pq/6.NpOCSzhbQlNy.cnG/
enable password donna
ip subnet-zero
ipx routing 1111.1111.1111
ipx ping-default novell
interface Ethernet0
 description r1e0 to hosta and hostb
 ip address 192.168.5.17 255.255.255.240
 no ip directed-broadcast
 ipx encapsulation SAP
 ipx network 516
interface Ethernet1
 description r1e1 to r2e0
 ip address 192.168.5.33 255.255.255.240
 no ip directed-broadcast
interface Serial0
 description r1s0 to r5s0
 bandwidth 64
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
interface Serial1
 description r1s1 to r3s0/0
 bandwidth 64
 ip address 192.168.5.81 255.255.255.240
 no ip directed-broadcast
router eigrp 500
 network 10.0.0.0
 network 192.168.5.0
 no auto-summary
ip classless
tftp-server flash:c2500-js-l.120-21a.bin
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password donna
 login
end

Example 5-2. r2 Configuration (2501)
r2#show running-config
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r2
enable secret 5 $1$5FjB$OHtAhTOCisLWIa5qzy3RJ1
enable password donna
ip subnet-zero
interface Ethernet0
 description r2e0 to r1e1
 ip address 192.168.5.34 255.255.255.240
 no ip directed-broadcast
interface Serial0
 description r2s0 to r3s0/1
 bandwidth 64
 ip address 192.168.5.65 255.255.255.240
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
interface Serial1
 description r2s1 to r3s0/2
 bandwidth 64
 ip address 192.168.5.49 255.255.255.240
 no ip directed-broadcast
router eigrp 500
 network 192.168.5.0
ip classless
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password donna
 login
end

Example 5-3. r3 Configuration (3640)
r3#show running-config
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r3
enable secret 5 $1$VA..$TqTkW/PwrI4bRPF1zjZCu1
enable password donna
ip subnet-zero
interface Serial0/0
 description r3s0/0 to r1s1
 bandwidth 64
 ip address 192.168.5.82 255.255.255.240
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 64000
interface Serial0/1
 description r3s0/1 to r2s0
 bandwidth 64
 ip address 192.168.5.66 255.255.255.240
 no ip directed-broadcast
 clockrate 64000
interface Serial0/2
 description r3s0/2 to r2s1
 bandwidth 64
 ip address 192.168.5.50 255.255.255.240
 no ip directed-broadcast
 clockrate 64000
interface Serial0/3
 description r3s0/3 to r4s0/0
 bandwidth 64
 ip address 10.2.2.1 255.255.255.0
 no ip directed-broadcast
...
interface FastEthernet2/0
 description r3fa2/0 to hostc
 ip address 192.168.5.97 255.255.255.240
 no ip directed-broadcast
router eigrp 500
 network 10.0.0.0
 network 192.168.5.0
 no auto-summary
ip classless
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password donna
 login
end

Example 5-4. r4 Configuration (3620)
r4#show running-config
Building configuration...
Current configuration:
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r4
enable secret 5 $1$C0Dd$kkBg8CqXD2ZVjcHq8uvxB/
enable password donna
interface Ethernet0/0
 no ip address
 shutdown
interface Serial0/0
 description r4s0/0 to r3s0/3
 ip address 10.2.2.2 255.255.255.0
 no ip mroute-cache
 bandwidth 64
 no fair-queue
 clockrate 64000
interface Serial0/1
 no ip address
 shutdown
router eigrp 500
 network 10.0.0.0
 no auto-summary
ip classless
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password donna
 login
end

Example 5-5. r5 Configuration (2516)
r5#show running-config
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r5
enable secret 5 $1$eozM$NyPHA2CFPGE4V4xV806YS0
enable password donna
ip subnet-zero
...
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
interface Serial0
 description r5s0 to r1s0
 bandwidth 64
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 64000
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
router eigrp 500
 network 10.0.0.0
 no auto-summary
ip classless
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password donna
 login
end

Next you should double-check your host configurations. Physically hosta, hostb, and the gwise server should be connected to r1e0 via a hub. Internetwork Packet Exchange (IPX) should be running on at least hostb, and IP should be running on all hosts. (See Table 5-2.)

Table 5-2. IP Host Configuration
 IP AddressSubnet MaskGateway
hosta192.168.5.18255.255.255.240192.168.5.17
hostb192.168.5.19255.255.255.240192.168.5.17
hostc192.168.5.98255.255.255.240192.168.5.97

Now that the routers and the hosts are configured for interoperability, test things out starting with r1 in Example 5-6. I started with show ip route because, most of the time, I don't assume that there is something wrong. If things are missing from the routing table, you need to investigate why.

Example 5-6. Verifying IP Routes on r1
r1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
Gateway of last resort is not set
     192.168.5.0/28 is subnetted, 6 subnets
D       192.168.5.96 [90/40514560] via 192.168.5.82, 00:39:19, Serial1
D       192.168.5.64 [90/40537600] via 192.168.5.34, 00:39:19, Ethernet1
C       192.168.5.80 is directly connected, Serial1
C       192.168.5.32 is directly connected, Ethernet1
D       192.168.5.48 [90/40537600] via 192.168.5.34, 00:39:19, Ethernet1
C       192.168.5.16 is directly connected, Ethernet0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/41024000] via 192.168.5.82, 00:39:19, Serial1
C       10.1.1.0 is directly connected, Serial0
r1#

Compare the output of Example 5-6 to Figure 5-1. Ensure that all of your directly connected routes are listed in your routing table as well as the EIGRP-learned routes. At a quick glance, the shaded output indicates six subnets under 192.168.5.0/28 and two subnets under 10.0.0.0/24. If any subnets are missing, investigate why.

Looking at the routing table is a quick way to troubleshoot many issues. If you are looking for a particular network, however, it is less confusing to just list the address after the show ip route command as in Example 5-7.

Example 5-7. Finding a Particular Route on r1
r1#show ip route 10.2.2.0
Routing entry for 10.2.2.0/24
  Known via "eigrp 500", distance 90, metric 41024000, type internal
  Redistributing via eigrp 500
  Last update from 192.168.5.82 on Serial1, 00:51:39 ago
  Routing Descriptor Blocks:
  * 192.168.5.82, from 192.168.5.82, 00:51:39 ago, via Serial1
      Route metric is 41024000, traffic share count is 1
      Total delay is 40000 microseconds, minimum bandwidth is 64 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
r1#

If your routing table looks like the one in Example 5-8 rather than the one in Example 5-6, refer back to Chapter 3, “Shooting Trouble with IP,” or research discontiguous subnets and EIGRP on Cisco.com for help.

Example 5-8. Missing Network 10.2.2.0
r1#show ip route
...
     192.168.5.0/24 is variably subnetted, 7 subnets, 2 masks
D       192.168.5.96/28 [90/2172416] via 192.168.5.82, 00:05:10, Serial1
D       192.168.5.64/28 [90/40537600] via 192.168.5.34, 00:15:18, Ethernet1
C       192.168.5.80/28 is directly connected, Serial1
C       192.168.5.32/28 is directly connected, Ethernet1
D       192.168.5.48/28 [90/40537600] via 192.168.5.34, 00:15:18, Ethernet1
D       192.168.5.0/24 is a summary, 00:23:00, Null0
C       192.168.5.16/28 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
						C       10.1.1.0/24 is directly connected, Serial0
						D       10.0.0.0/8 is a summary, 00:11:38, Null0
r1#

From your research, you should have found that EIGRP handles discontiguous subnets just like RIPv2 does. For this to work properly, you must use the no auto-summary command in the router configuration mode. Your routing table hint should have been the automatic classful summarization of 192.168.5.0/24 and 10.0.0.0/8 with a summary route to null0. A quick ping test from hosta to hostc would have illustrated end-to-end host connectivity, but would not have brought out any network 10.0.0.0 issues. However, r2 would have been pretty confused as to which way to direct the packets for network 10.0.0.0.

Next verify that IPX and RIP are running on r1e0 with me in Example 5-9.

Example 5-9. Verify IPX on r1
r1#show ipx route
Codes: C - Connected primary network,    c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static
2 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
No default route known.
C        516 (SAP),           Et0
						R   346648E2 [02/01] via      516.0080.29e8.5c6b,   56s, Et0
r1#show ipx interface ethernet 0
Ethernet0 is up, line protocol is up
  IPX address is 516.0000.0c8d.6705, SAP [up]
  Delay of this IPX network, in ticks is 1 throughput 0 link delay 0
...
  RIP packets received 119, RIP packets sent 3977
  SAP packets received 117, SAP packets sent 1
r1#show ipx servers
Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail
U - Per-user static
4 Total IPX Servers
Table ordering is based on routing and server info
   Type Name                       Net     Address    Port     Route Hops Itf
P     4 GWISE                 346648E2.0000.0000.0001:0451      2/01   1  Et0
P   107 GWISE                 346648E2.0000.0000.0001:8104      2/01   1  Et0
P   26B GWISE_TREE___________ 346648E2.0000.0000.0001:0005      2/01   1  Et0
P   278 GWISE_TREE___________ 346648E2.0000.0000.0001:4006      2/01   1  Et0
r1#ping ipx 346648e2.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to 346648E2.0000.0000.0001, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r1#

Although not shown in these examples, the rest of the routers have the correct information in their routing tables. Verify yours now. Perform some ping tests from every router (like I do with r2 in Example 5-10).

Example 5-10. r2 Ping Testing
r2>ping 192.168.5.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r2>ping 192.168.5.82
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.82, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms
r2>ping 192.168.5.97
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms
r2>ping 10.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms
r2>

Finally, analyze the host routing tables and ping from hosta and hostb to hostc to test end-to-end host connectivity as in Example 5-11. To test the higher layers, feel free to run an application such as Telnet, TFTP, or FTP. If you can copy all of your configuration files to the same TFTP server, for example, that would test from the Physical to the Application Layers. Alternatively, if you can Telnet to every router from every host, that is another good test of all the layers.

Example 5-11. Testing End-to-End Connectivity from hosta to hostc
C:>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...44 45 53 54 42 00 ...... NOC Extranet Access Adapter
0x1000004 ...00 10 4b a5 ae 50 ...... FE575 Ethernet Adapter
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     192.168.5.17    192.168.5.18       1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
     192.168.5.16  255.255.255.240     192.168.5.18    192.168.5.18       1
     192.168.5.18  255.255.255.255        127.0.0.1       127.0.0.1       1
    192.168.5.255  255.255.255.255     192.168.5.18    192.168.5.18       1
        224.0.0.0        224.0.0.0     192.168.5.18    192.168.5.18       1
  255.255.255.255  255.255.255.255     192.168.5.18               2       1
Default Gateway:      192.168.5.17
===========================================================================
Persistent Routes:
  None
C:>ping 192.168.5.98
Pinging 192.168.5.98 with 32 bytes of data:
Reply from 192.168.5.98: bytes=32 time=20ms TTL=126
Reply from 192.168.5.98: bytes=32 time=10ms TTL=126
Reply from 192.168.5.98: bytes=32 time=10ms TTL=126
Reply from 192.168.5.98: bytes=32 time=10ms TTL=126
Ping statistics for 192.168.5.98:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 10ms, Maximum =  20ms, Average =  12ms
C:>arp -a
Interface: 192.168.5.18 on Interface 0x1000004
  Internet Address      Physical Address      Type
  192.168.5.17          00-00-0c-8d-67-05     dynamic
C:>tracert 192.168.5.98
Tracing route to HOSTC [192.168.5.98]
over a maximum of 30 hops:
  1   <10 ms    10 ms   <10 ms  192.168.5.17
  2    20 ms    20 ms    20 ms  192.168.5.82
  3    20 ms    30 ms    30 ms  HOSTC [192.168.5.98]
Trace complete.
C:>

NOTE

If you are seeing other routes in your routing table, you may be connected to the Internet via your Internet service provider (ISP). Disconnect to alleviate the confusion, for the labs in this book assume you are connected only to what is in the scenario drawings.


These tools are the same tools you have been using throughout this book and are the same tools you will continue to use in supporting day-to-day networks. If Layer 3 is working, so are Layer 2 and Layer 1). The ping from hosta to hostc verifies that you can communicate to a remote network unless an access list or something is blocking a particular address, network, or application port. Don't forget to verify the same tests from hostb to hostc. Compare the Address Resolution Protocol (ARP) tables on the hosts to the ARP table on r1 as in Example 5-12. At first my ARP table on r1 did not display an entry for hostb, but later I found that I had an incorrect IP address configured for hostb. When I fixed that, the ARP table was correct.

Example 5-12. r1 ARP Table
r1>show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.5.33            -   0000.0c8d.6706  ARPA   Ethernet1
Internet  192.168.5.34          157   0000.0c38.a05d  ARPA   Ethernet1
Internet  192.168.5.17            -   0000.0c8d.6705  ARPA   Ethernet0
Internet  192.168.5.18            2   0010.4ba5.ae50  ARPA   Ethernet0
!!!fixed ip address on hostb here
r1>show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.5.33            -   0000.0c8d.6706  ARPA   Ethernet1
Internet  192.168.5.34          174   0000.0c38.a05d  ARPA   Ethernet1
Internet  192.168.5.17            -   0000.0c8d.6705  ARPA   Ethernet0
Internet  192.168.5.19            0   0080.c7aa.c887  ARPA   Ethernet0
Internet  192.168.5.18           18   0010.4ba5.ae50  ARPA   Ethernet0
r1>

For a change, everything is successful for this chapter scenario. However, you must be familiar with the right tools to help you find and narrow the problem down into its components. Besides ping, trace, ARP, and routing tables, Cisco Discovery Protocol (CDP) is quite helpful in initial troubleshooting steps as well.

Ethernet operates at Layer 1 and Layer 2 and lower layer targets in general are interfaces and controllers. A quick test for host or router communications is to ping from end-to-end as you did in the previous examples. However, what if the end-to-end ping fails? The tracert command in Example 5-11 illustrates the exact path the packets took from hosta to hostc. The hop-by-hop display can assist with finding where the pings are failing. The ping and trace tools most definitely complement one another and should be used together.

NOTE

As emphasized in Chapter 2, “What's in Your Tool Bag?” you should use ping to identify lower-level troubleshooting targets. Ping the loopback address (127.0.0.1), ping yourself (your IP address), ping someone local, ping the default gateway, and ping a remote host. I must tell you, however, that many times I skip the local activity and just try my gateway first; then I can work from there. If you are still having problems, trace is a great companion utility to ping. The ping and trace tools complement one another. Ping shows connectivity and delay up to Layer 3, and trace shows the path from the source to the destination. Don't forget about the extended versions of both of them from the enable mode. For example, perhaps the issue is your gateway and you can source the ping from another interface.


Continue to use a layered methodology yet divide and conquer to fix any problems at this time. Refer back to the previous chapters' quick troubleshooting checklists for hints.

Next I want to focus a little more on lower-layer targets. It is vital to look at interfaces and controllers to assist with Ethernet troubleshooting at the Data Link Layer. Documentation such as charts and drawings make this much easier. In addition, the ping statistics prove quite useful to see whether a link is down or there is some type of congestion. If a problem exists between the source and the destination, trace is useful to narrow down where to start your troubleshooting.

Use the commands in Table 5-3 to prepare a page of documentation for each one of your routers. Appendix B, “Troubleshooting Resources,” includes this as a router documentation template for your use.

Table 5-3. Commands to Help You Document Your Routers
CommandInformation Provided
show versionIOS, RAM, Flash, and configuration register
show cdp neighbors detailIP, device, and IOS version, and the connected interfaces
show ip interface briefStatus and IP
show ipx interface briefNetwork, encapsulation, IPX status and state
show interfaces [interface]MAC, IP, Bandwidth (BW), encapsulation, keepalive, duplex, and speed
show ip interface [interface]IP statistics
show ipx interface [interface]IPX statistics
show protocolsIP and IPX routing process and addresses
show ip protocolsRouting protocol and details, including summarization and redistribution
show access-lists

show ip access-lists

[access-list]

show ipx access-lists

[access-list]
Access Lists (ACLs) and hits

The commands on r1 appear in Example 5-13 through Example 5-20. You will thank yourself not only during the Trouble Tickets but also in the real world if you take the time to do this up front. Alternatively, you can get a very large sheet of paper and increase the size of your scenario drawing so that you have room for all the minute details that may assist you in troubleshooting later. Many network management programs capture these statistics automatically for you today. However, people like you and I still need to know where to start to get things back to normal when lights and alerts go off. It helps to have a drawing and the detailed data if someone comes to you with a real Trouble Ticket to solve.

Example 5-13. r1 show version
r1#show version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(21a), RELEASE SOFTWARE (fc1)
Copyright  1986-2002 by cisco Systems, Inc.
Compiled Sat 02-Feb-02 02:08 by nmasa
Image text-base: 0x030520E0, data-base: 0x00001000
ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)
r1 uptime is 3 days, 21 hours, 24 minutes
System restarted by power-on
System image file is "flash:c2500-js-l.120-21a.bin"
						cisco 2500 (68030) processor (revision L) with 14336K/2048K bytes of memory.
Processor board ID 03074719, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
2 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)
						Configuration register is 0x2102
					

Example 5-14. r1 Neighbors
r1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
r2                  Eth 1          157           R        2500      Eth 0
						r3                  Ser 1          174           R        3640      Ser 0/0
						r5                  Ser 0          132           R        2516      Ser 0
r1#show cdp neighbors detail
-------------------------
Device ID: r2
Entry address(es):
  IP address: 192.168.5.34
						Platform: cisco 2500,  Capabilities: Router
						Interface: Ethernet1,  Port ID (outgoing port): Ethernet0
Holdtime : 149 sec
Version :
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(21a), RELEASE SOFTWARE (fc1)
Copyright  1986-2002 by cisco Systems, Inc.
Compiled Sat 02-Feb-02 02:08 by nmasa
-------------------------
Device ID: r3
Entry address(es):
  IP address: 192.168.5.82
						Platform: cisco 3640,  Capabilities: Router
						Interface: Serial1,  Port ID (outgoing port): Serial0/0
Holdtime : 164 sec
Version :
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-JS-M), Version 12.0(13), RELEASE SOFTWARE (fc1)
Copyright  1986-2000 by cisco Systems, Inc.
Compiled Tue 05-Sep-00 21:39 by linda
-------------------------
Device ID: r5
Entry address(es):
  IP address: 10.1.1.2
						Platform: cisco 2516,  Capabilities: Router
						Interface: Serial0,  Port ID (outgoing port): Serial0
Holdtime : 121 sec
Version :
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(21a), RELEASE SOFTWARE (fc1)
Copyright  1986-2002 by cisco Systems, Inc.
Compiled Sat 02-Feb-02 02:08 by nmasa

Example 5-15. r1 Brief Interface Statistics
r1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              192.168.5.17    YES manual up                    up
						Ethernet1              192.168.5.33    YES manual up                    up
						Serial0                10.1.1.1        YES manual up                    up
						Serial1                192.168.5.81    YES manual up                    up
r1#show ipx interface brief
Interface            IPX Network Encapsulation Status                 IPX State
Ethernet0            516         SAP           up                     [up]
Ethernet1            unassigned  not config'd  up                     n/a
Serial0              unassigned  not config'd  up                     n/a
Serial1              unassigned  not config'd  up                     n/a

Example 5-16. r1 Interface Statistics
r1#show interfaces
						Ethernet0 is up, line protocol is up
						Hardware is Lance, address is 0000.0c8d.6705 (bia 0000.0c8d.6705)
						Description: r1e0 to hosta and hostb
						Internet address is 192.168.5.17/28
						MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
						Encapsulation ARPA, loopback not set, keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output 00:00:01, output hang never
  Last clearing of "show interface" counters 1d03h
Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     8201 packets input, 1586890 bytes, 0 no buffer
     Received 7778 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     33932 packets output, 2793718 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Ethernet1 is up, line protocol is up
						Hardware is Lance, address is 0000.0c8d.6706 (bia 0000.0c8d.6706)
						Description: r1e1 to r2e0
						Internet address is 192.168.5.33/28
						MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
						Encapsulation ARPA, loopback not set, keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:04, output hang never
  Last clearing of "show interface" counters 1d03h
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     23310 packets input, 2098244 bytes, 0 no buffer
     Received 23260 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     33572 packets output, 2717907 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 1 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0 is up, line protocol is up
						Hardware is HD64570
						Description: r1s0 to r5s0
						Internet address is 10.1.1.1/24
						MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
						Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:03, output 00:00:00, output hang never
  Last clearing of "show interface" counters 1d03h
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     33112 packets input, 2054389 bytes, 0 no buffer
     Received 11686 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     33165 packets output, 2058532 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Serial1 is up, line protocol is up
						Hardware is HD64570
						Description: r1s1 to r3s0/0
						Internet address is 192.168.5.81/28
						MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
						Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 1d03h
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     33646 packets input, 2123261 bytes, 0 no buffer
     Received 11701 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     33764 packets output, 2105641 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Example 5-17. IP Interface Defaults and Settings
r1#show ip interface
						Ethernet0 is up, line protocol is up
						Internet address is 192.168.5.17/28
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  Web Cache Redirect is disabled
  BGP Policy Mapping is disabled
Ethernet1 is up, line protocol is up
						Internet address is 192.168.5.33/28
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  Web Cache Redirect is disabled
  BGP Policy Mapping is disabled
Serial0 is up, line protocol is up
						Internet address is 10.1.1.1/24
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Fast switching turbo vector
  IP multicast fast switching is disabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  Web Cache Redirect is disabled
  BGP Policy Mapping is disabled
Serial1 is up, line protocol is up
						Internet address is 192.168.5.81/28
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  Web Cache Redirect is disabled
  BGP Policy Mapping is disabled

Example 5-18. IPX Interface Ethernet 0 Statistics
r1#show ipx interface ethernet 0
						Ethernet0 is up, line protocol is up
						IPX address is 516.0000.0c8d.6705, SAP [up]
						Delay of this IPX network, in ticks is 1 throughput 0 link delay 0
  IPXWAN processing not enabled on this interface.
  IPX SAP update interval is 60 seconds
  IPX type 20 propagation packet forwarding is disabled
  Incoming access list is not set
  Outgoing access list is not set
  IPX helper access list is not set
  SAP GNS processing enabled, delay 0 ms, output filter list is not set
  SAP Input filter list is not set
  SAP Output filter list is not set
  SAP Router filter list is not set
  Input filter list is not set
  Output filter list is not set
  Router filter list is not set
Netbios Input host access list is not set
  Netbios Input bytes access list is not set
  Netbios Output host access list is not set
  Netbios Output bytes access list is not set
  Updates each 60 seconds aging multiples RIP: 3 SAP: 3
  SAP interpacket delay is 55 ms, maximum size is 480 bytes
  RIP interpacket delay is 55 ms, maximum size is 432 bytes
  RIP response delay is not set
  IPX accounting is disabled
  IPX fast switching is configured (enabled)
  RIP packets received 1659, RIP packets sent 3977
  SAP packets received 1653, SAP packets sent 1

Example 5-19. r1 Protocol Commands
r1#show protocols
						Global values:
						Internet Protocol routing is enabled
						IPX routing is enabled
						Ethernet0 is up, line protocol is up
						Internet address is 192.168.5.17/28
						IPX address is 516.0000.0c8d.6705
						Ethernet1 is up, line protocol is up
						Internet address is 192.168.5.33/28
						Serial0 is up, line protocol is up
						Internet address is 10.1.1.1/24
						Serial1 is up, line protocol is up
						Internet address is 192.168.5.81/28
r1#show ip protocols
						Routing Protocol is "eigrp 500"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 500
						Automatic network summarization is not in effect
						Routing for Networks:
						10.0.0.0
						192.168.5.0
						Routing Information Sources:
						Gateway         Distance      Last Update
						(this router)          5      1d03h
						10.1.1.2              90      05:21:22
						192.168.5.82          90      05:21:24
						192.168.5.34          90      05:21:23
						Distance: internal 90 external 170
					

Example 5-20. Access Lists
r1#show access-lists
r1#show ip access-lists
r1#show ipx access-lists
r1#

As you can see, the commands presented in Table 5-3 are helpful to compile the documentation presented in Figure 5-2. You should be feeling much better about the importance of documentation. Pictures and tables help capture lots of useful information that saves you a great deal of time when it comes to troubleshooting. This makes it easy to spot any inconsistencies. In the practical environment, I would much rather do more work up front rather than when people are waiting for me to fix something.

Figure 5-2. r1 Documentation


NOTE

Although I have provided documentation only for r1, you should now repeat this for every device in your lab. Use the r1 worksheet in Figure 5-2 as a template. If you are using higher end routers/switches for your lab, add modules and slots to your documentation. I cover that more in Chapter 6, “Shooting Trouble with CatOS and IOS,” and Chapter 7, “Shooting Trouble with VLANs on Routers and Switches.”


Now that the existing Ethernet scenario is documented, I briefly discuss Ethernet and then cover Ethernet Data Link and Physical Layer troubleshooting targets in more detail.

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset
18.191.254.116